srpurdy

Well-Known Member
Jun 1, 2011
101
0
66
cPanel Access Level
Root Administrator
Is there any idea when suHosin will have an available option on php 5.4?

I'd like to switch to PHP5.4 but can't really do so until suHosin is working for php 5.4. I know that extension has had it's issues in terms of development. Just wondering when it might be available. :)

Thanks!
 

aww

Well-Known Member
Feb 10, 2005
152
0
166
cPanel Access Level
Root Administrator
Whoa I just noticed suhosin was not loading after we recompiled for php 5.4 this morning.

Wish I had known it wasn't working yet, this is a showstopper as it's too dangerous without it.

Wait, the DEV version has 5.4 support, I will compile manually: https://github.com/stefanesser/suhosin

Ah it seemed to compile and passed make test but it didn't work, throwing errors:

/usr/local/apache/bin/httpd: symbol lookup error: /usr/local/lib/php/extensions/no-debug-non-zts-20100525/suhosin.so: undefined symbol: php_mb_encoding_translation
 
Last edited:

LeadDogGraphics

Well-Known Member
Feb 25, 2012
97
1
58
West Palm Beach, FL
cPanel Access Level
Root Administrator
Whoa I just noticed suhosin was not loading after we recompiled for php 5.4 this morning.

Wish I had known it wasn't working yet, this is a showstopper as it's too dangerous without it.

Wait, the DEV version has 5.4 support, I will compile manually: https://github.com/stefanesser/suhosin

Ah it seemed to compile and passed make test but it didn't work, throwing errors:

/usr/local/apache/bin/httpd: symbol lookup error: /usr/local/lib/php/extensions/no-debug-non-zts-20100525/suhosin.so: undefined symbol: php_mb_encoding_translation
Yeah I saw the DEV version a few weeks ago, and if you read the notes in the project, it will compile for 5.4 but not actually work yet, it is still not running completely. I sure wish the Dev would put out a call for help if he is not able to dedicate time to the project. This is the problem with Open Source software, that program is used by who knows how many millions of servers, yet no one wishes to help out, I don't know how to code, but would surely send a donation to help but the Dev seams to be MIA mostly.
 

aww

Well-Known Member
Feb 10, 2005
152
0
166
cPanel Access Level
Root Administrator
Well it is open source, we could put a bounty out for proper 5.4 support on one of the sites that does that.
 

cPanelKevinS

Member
Staff member
Mar 7, 2013
8
0
1
As bangjampang pointed out, the upstream project has been idle, and in a PHP 5.4 incompatible state, for nearly a year. But last month the maintainer stated his intention to devote some time in May to addressing the remaining PHP 5.4 related issues:

https://github.com/stefanesser/suhosin/issues/27

Obviously we can't make any promises on when (or even if) an update will be available, but we will continue monitoring the project.
 

k2tec

Well-Known Member
Aug 26, 2011
104
5
68
Netherlands
cPanel Access Level
Root Administrator
I also run easyapache with php5.4.x still no luck with suhosin.

I am getting these errors.

Code:
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-non-zts-20100525/suhosin.so' - /usr/local/lib/php/extensions/no-debug-non-zts-20100525/suhosin.so: cannot open shared object file: No such file or directory in Unknown on line 0
How to get rid of those error.
All my customer accounts are running full with the error log