The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

9.9.2-STABLE 8 not working with phpbb 2.0.6 ?

Discussion in 'General Discussion' started by ChristianR, Oct 18, 2004.

  1. ChristianR

    ChristianR Registered

    Joined:
    Oct 18, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    my hosting company just upgraded to 9.9.2-STABLE 8 of cpanel (I believe), as now my phpbb 2.0.6 forum does no longer work!

    My phpbb 2.0.6 is very customized, and was working perfect prior to the lastest upgrade.

    IS their anyway to get phpbb 2.0.6 to work with the latest cpanel release? and why does it now allow this version to run?
     
  2. SarcNBit

    SarcNBit Well-Known Member

    Joined:
    Oct 14, 2003
    Messages:
    1,010
    Likes Received:
    3
    Trophy Points:
    38
    It is most likely not an issue with the cPanel version per se, it is likely an issue with the php version. Your phpbb v2.0.6 board is most likely insecure no matter how customized it is, and you would do well to update to a newer version.

    With that being said, it is known that php 2.0.x is incompatible with the 'register_long_arrays = off' setting in newer versions of php. Your host might be willing to look at that value and adjust it to accomodate your needs.
     
  3. ChristianR

    ChristianR Registered

    Joined:
    Oct 18, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Well they told me to update to .10 release and it will work.

    But since it is customised (using catergory heriachy mod and many others mods) I doubt it will be simple.

    and since I can't see the forum running at the mo, just shows a white page, going to be a bit difficult to update it :)

    Does phpbb 2.0.10 work with the setting on? as if it does, then that could be a way or resolving.
     
  4. Aric1

    Aric1 Well-Known Member

    Joined:
    Oct 15, 2003
    Messages:
    324
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    If you go to phpbb.com, you can find instructions for every upgrade from 2.0.6 - 2.0.10 listed as if it were a mod. Just follow each one 2.0.6 --> 2.0.7 2.0.7 --> 2.0.8 etc. until you are completely up-to-date. Even with highly modified boards, the process is fairly straight-forward if you are careful.
     
  5. SarcNBit

    SarcNBit Well-Known Member

    Joined:
    Oct 14, 2003
    Messages:
    1,010
    Likes Received:
    3
    Trophy Points:
    38
    All 2.0.x versions work with the setting on. Off is the problem :)

    If you upgrade to 2.0.10 however you should not have to worry about it because they have made changes to allow it to work.
     
  6. ChristianR

    ChristianR Registered

    Joined:
    Oct 18, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Well i know version 2.0.10 works, however I do not want to upgrade to it, if I do not have to.

    And if I did have to, I would have liked the hosting company to at least give me a demo server to try it on to make sure all mods work, rather than my users just seeing a blank white page!
     
  7. Aric1

    Aric1 Well-Known Member

    Joined:
    Oct 15, 2003
    Messages:
    324
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    I can't answer for your host, but from a security standpoint, it would be a very good thing for you to upgrade. phpBB is focused on the next major version so the past several releases of 2.0.x have almost entirely on fixing security issues. Of course, you can do what you want.
     
  8. ChristianR

    ChristianR Registered

    Joined:
    Oct 18, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    i know, but i just don't understand why it suddenly stopped working with the latest version of cpanel.

    quite annoying!
     
  9. SarcNBit

    SarcNBit Well-Known Member

    Joined:
    Oct 14, 2003
    Messages:
    1,010
    Likes Received:
    3
    Trophy Points:
    38
    They most likely upgraded to a more secure version of php. From a host point of view, I do not really empathize with you. Running outdated version of software creates security holes and in a shared server environment that affects people with no control over updating your software. phpbb v2.0.6 is insecure and running it could cause problems either for you or those that share your server.

    You should not be complaining that your host is keeping your server secure. You would certainly complain if you suddently found all of your web pages defaced and/or your data destroyed.

    Version 2.0.6 was released more than a year ago. There have been no fewer than 6 security related version updates since that time. If you neglected to keep your board updated and are now faced with updating all at once, whose fault is that? Blame phpBB for releasing 2.0.6 with security holes, maybe they will give you your money back.
     
Loading...

Share This Page