The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

9.9.9 and spamd failed

Discussion in 'General Discussion' started by grgur, Dec 10, 2004.

  1. grgur

    grgur Member

    Joined:
    Sep 2, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Split, Croatia
    I have just upgraded to

    WHM 9.9.9 cPanel 9.9.9-S11
    CentOS 3.3 i686 - WHM X v3.1.0

    and now I get spamd failed at serice status panel. :confused:

    Anyone has a clue?
     
  2. Sinewy

    Sinewy Well-Known Member

    Joined:
    May 15, 2004
    Messages:
    367
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Sydney, Australia
    cPanel Access Level:
    DataCenter Provider
    look for Install a Perl Module under Software in whm: type in Digest::SHA1

    when the list appears, select Digest::SHA1.

    when done:

    login to SSH as root and execute the following:

    /scripts/restartsrv exim
    /scripts/restartsrv spamd
    /etc/init.d/chkservd restart
     
  3. eth00

    eth00 Well-Known Member
    PartnerNOC

    Joined:
    Mar 30, 2003
    Messages:
    723
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    NC
    cPanel Access Level:
    Root Administrator
    After I did the above spamassasin would not start at all. I had to install the Mail::SpamAssassin::NoMailAudit module as well.
     
  4. grgur

    grgur Member

    Joined:
    Sep 2, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Split, Croatia
    Thanks guys, I did all that you wrote and it helped in the way that now I'm able to restart spamd (I had an error before). It all seems to be working well when I run it from ssh, but I still get a red light and failed message for spam :confused: :confused:
     
  5. dreamwiz

    dreamwiz Well-Known Member

    Joined:
    Aug 28, 2003
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    6
    same here, it restarts well in ssh but whm gives a red light.
     
  6. eth00

    eth00 Well-Known Member
    PartnerNOC

    Joined:
    Mar 30, 2003
    Messages:
    723
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    NC
    cPanel Access Level:
    Root Administrator
    Did you restart ckserv? It is working fine for me. I did have what I thought were unrelated problems and had to reinstall clamav+eximscan, maybe that will help you guys.
     
  7. dreamwiz

    dreamwiz Well-Known Member

    Joined:
    Aug 28, 2003
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    6
    /scripts/perlinstaller --force Mail::SpamAssassin
    /etc/rc.d/init.d/exim restart

    This should fix it. Thanks to Kyle Pinkley @ Cpanel support.
     
  8. grgur

    grgur Member

    Joined:
    Sep 2, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Split, Croatia
    Thanks for your effort guys, but still nothing happens. I wonder if ti is better never to update cpanel!?
     
  9. NetX

    NetX Well-Known Member

    Joined:
    Jun 18, 2003
    Messages:
    177
    Likes Received:
    0
    Trophy Points:
    16
    It works for me

    It works for me:

    /scripts/perlinstaller --force Mail::SpamAssassin
    /etc/rc.d/init.d/exim restart
    /scripts/restartsrv spamd

    :)
     
  10. grgur

    grgur Member

    Joined:
    Sep 2, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Split, Croatia
    I did all that and this is what I got:

    ....
    # /scripts/restartsrv spamd
    Waiting for spamd to restart..............finished.

    root 23178 5.3 4.4 26076 22244 ? S 21:35 0:00 /usr/bin/spamd -d --pidfile=/var/run/spamd.pid --max-children=3
    root 23179 0.0 4.4 26076 22244 ? S 21:35 0:00 spamd child

    spamd has failed, please contact the sysadmin (result was "Spamd is not running").
     
  11. NetX

    NetX Well-Known Member

    Joined:
    Jun 18, 2003
    Messages:
    177
    Likes Received:
    0
    Trophy Points:
    16
    try restarting exim before
     
  12. grgur

    grgur Member

    Joined:
    Sep 2, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Split, Croatia
    this is the entire sequence

    /scripts/perlinstaller Digest::SHA1
    /scripts/perlinstaller --force Mail::SpamAssassin
    /etc/rc.d/init.d/exim restart
    /scripts/restartsrv spamd
     
  13. freakysid

    freakysid Well-Known Member

    Joined:
    Mar 5, 2002
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    no luck for me

    WHM 9.9.8 cPanel 9.9.8-R119
    RedHat 7.3 i686 - WHM X v3.1.0

    Tried everything mentioned in this thread:
    Code:
    root@wombat [~]# /scripts/restartsrv spamd
    Waiting for spamd to restart..............finished.
    
    
    spamd has failed, please contact the sysadmin (result was "Spamd is not running").
    
     
  14. fikse

    fikse Well-Known Member

    Joined:
    May 10, 2003
    Messages:
    112
    Likes Received:
    0
    Trophy Points:
    16
    I had a similar issue.... spamd kept failing after updating whm and redhat....

    have you tried:

    /scripts/fixspamassassinfailedupdate
     
  15. freakysid

    freakysid Well-Known Member

    Joined:
    Mar 5, 2002
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    Tried that - no luck :( - thanks though.
     
  16. freakysid

    freakysid Well-Known Member

    Joined:
    Mar 5, 2002
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    My issue was fixed by cpanel support - there was a corrupt line in my spamassassin config file.
     
  17. grgur

    grgur Member

    Joined:
    Sep 2, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Split, Croatia
    Do you have any details about that line?
     
  18. viooltje

    viooltje Well-Known Member

    Joined:
    Mar 14, 2004
    Messages:
    60
    Likes Received:
    0
    Trophy Points:
    6
    I have tried these not helping me

    /scripts/perlinstaller Digest::SHA1
    /scripts/perlinstaller --force Mail::SpamAssassin
    /etc/rc.d/init.d/exim restart
    /scripts/restartsrv spamd
    /etc/init.d/chkservd restart
    /scripts/fixspamassassinfailedupdate


    try this it helped me with the -a

    service spamassassin restart

    Shutting down spamd: [ OK ]
    Starting spamd: The -a option has been removed. Please look at the use_auto_whitelist config option instead.

    pico /etc/sysconfig/spamassassin
    # Options to spamd
    SPAMDOPTIONS="-d -c -a"
    make it like this
    # Options to spamd
    SPAMDOPTIONS="-d -c"


    service spamassassin restart
    Shutting down spamd: [ OK ]
    Starting spamd: [ OK ]

    but the problem is I really dunno what the -a stand for or what it does if it's diabling the anti virus check then it's even worse.


    sorry the light is burning again it was no help to turn off the whm service status lamp aaarg
     
    #18 viooltje, Dec 25, 2004
    Last edited: Dec 25, 2004
  19. Sinewy

    Sinewy Well-Known Member

    Joined:
    May 15, 2004
    Messages:
    367
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Sydney, Australia
    cPanel Access Level:
    DataCenter Provider
    service chkservd restart in SSH so chkservd checks all services again
     
  20. Dreamer

    Dreamer Well-Known Member

    Joined:
    Jun 23, 2003
    Messages:
    129
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Bulgaria
    Thanks. This helped me so far :)
     
Loading...

Share This Page