The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

__cpanel__service__check__

Discussion in 'General Discussion' started by Tymsah, Mar 1, 2011.

  1. Tymsah

    Tymsah Well-Known Member

    Joined:
    Apr 6, 2007
    Messages:
    151
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Hi,

    how can i fix this issue

    /usr/local/cpanel/logs/access_log
    178.#.###.### - - [03/01/2011:20:58:53 -0000] "POST /.__cpanel__service__check__./serviceauth HTTP/1.0" 401 0 "" ""
    178.#.###.### - - [03/01/2011:21:03:54 -0000] "POST /.__cpanel__service__check__./serviceauth HTTP/1.0" 401 0 "" ""
    178.#.###.### - - [03/01/2011:21:08:54 -0000] "POST /.__cpanel__service__check__./serviceauth HTTP/1.0" 401 0 "" ""
    178.#.###.### - - [03/01/2011:21:13:55 -0000] "POST /.__cpanel__service__check__./serviceauth HTTP/1.0" 401 0 "" ""
    178.#.###.### - - [03/01/2011:21:18:57 -0000] "POST /.__cpanel__service__check__./serviceauth HTTP/1.0" 401 0 "" ""
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    This is not an issue but a service check by chkservd to check that the service in question is working. This is why you will see these every 5 minutes, since the services in WHM > Service Manager are checked every 5 minutes.
     
  3. Tymsah

    Tymsah Well-Known Member

    Joined:
    Apr 6, 2007
    Messages:
    151
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    thank you for help
    i see this error

    /var/log/chkservd.log
    ------
    cpsrvd [cpsrvd: [HTTP/1.1 401 Access Denied != HTTP/1.x 200 OK] [key=<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml"><head><link rel="shortcut icon" href="/unprotected/cpanel/favicon.ico" type="image/x-icon" /><meta http-equiv="Content-Type" content="text/html; charset=utf-8" /><title>cPanel&reg; 11</title><link rel="stylesheet" href="/unprotected/cpanel/style_optimized.css" type="text/css" /><meta name="robots" content="noindex, nofollow" /></head><body><div id="wrap"> <div id="top-whm"> </div> <div id="mid"> <div id="content-wrap" align="center"> <form action="/login/" method="post" > <input type="hidden" name="login_theme" value="cpanel" /> <table width="200px" class="login" cellpadding="0" cellspacing="0"> <tr> <td align="left" colspan="2"><strong>Login</strong></td> </tr> <tr> <td class="login_lines">Username&nbsp;</td> <td class="login_lines"><input autofocus="autofocus" type="text" id="user" name="user" size="16" /></td> </tr> <tr class="row2"> <td class="login_lines">Password&nbsp;</td> <td class="login_lines"><input type="password" id="pass" name="pass" size="16" /></td> </tr> <tr> <td colspan="2" style="text-align: center"><input type="submit" id="login" value="Login" class="input-button" /></td> </tr> </table> <input type="hidden" name="goto_uri" value="/.__cpanel__service__check__./serviceauth" /> <input type="hidden" name="reset_tokens" value="1" /></form><script type="text/javascript">//<![CDATA[ document.getElementById("user").focus();/* Must not include external javascript -jnk 06.20.09 *///]]></script></div></div><div id="bot-whm"></div>&copy; cPanel, Inc. 2009</div></body></html>] [expected_key=xxxx]
    [check command:N/A][tcp connect:-]Restarting cpsrvd....
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Is that occurring constantly now or was it simply at some time in the past? Please try running the following command:

    Code:
    /scripts/restartsrv_chkservd
    Then tail the log:

    Code:
    tail -f /var/log/chkservd.log
     
  5. Tymsah

    Tymsah Well-Known Member

    Joined:
    Apr 6, 2007
    Messages:
    151
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Service Check Started
    Loading services .....clamd....cpanellogd....cpsrvd....exim....exim-587....ftpd....httpd....imap....lfd....mysql....named....pop....queueprocd....spamd....sshd....syslogd..Done
    [2011-03-02 00:06:04 +0200] Service check ....syslogd [[check command:+][tcp connect:N/A]]...sshd [[check command:+][tcp connect:N/A]]...spamd [[check command:+][tcp connect:N/A]]...queueprocd [[check command:+][tcp connect:N/A]]...pop [[check command:N/A][tcp connect:+]]...named [[check command:+][tcp connect:N/A]]...mysql [[check command:+][tcp connect:N/A]]...melange [[check command:N/A][tcp connect:N/A]]...mailman [[check command:N/A][tcp connect:N/A]]...lfd [[check command:+][tcp connect:N/A]]...imap [[check command:+][tcp connect:+]]...httpd [[check command:N/A][tcp connect:+]]...ftpd [[check command:+][tcp connect:+]]...exim-587 [[check command:N/A][tcp connect:+]]...exim [[check command:+][tcp connect:+]]...entropychat [[check command:N/A][tcp connect:N/A]]...cpsrvd [cpsrvd: [HTTP/1.1 401 Access Denied != HTTP/1.x 200 OK] [key=<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html xmlns="http://www.w3.org/1999/xhtml"><head><link rel="shortcut icon" href="/unprotected/cpanel/favicon.ico" type="image/x-icon" /><meta http-equiv="Content-Type" content="text/html; charset=utf-8" /><title>cPanel&reg; 11</title><link rel="stylesheet" href="/unprotected/cpanel/style_optimized.css" type="text/css" /><meta name="robots" content="noindex, nofollow" /></head><body><div id="wrap"> <div id="top-whm"> </div> <div id="mid"> <div id="content-wrap" align="center"> <form action="/login/" method="post" > <input type="hidden" name="login_theme" value="cpanel" /> <table width="200px" class="login" cellpadding="0" cellspacing="0"> <tr> <td align="left" colspan="2"><strong>Login</strong></td> </tr> <tr> <td class="login_lines">Username&nbsp;</td> <td class="login_lines"><input autofocus="autofocus" type="text" id="user" name="user" size="16" /></td> </tr> <tr class="row2"> <td class="login_lines">Password&nbsp;</td> <td class="login_lines"><input type="password" id="pass" name="pass" size="16" /></td> </tr> <tr> <td colspan="2" style="text-align: center"><input type="submit" id="login" value="Login" class="input-button" /></td> </tr> </table> <input type="hidden" name="goto_uri" value="/.__cpanel__service__check__./serviceauth" /> <input type="hidden" name="reset_tokens" value="1" /></form><script type="text/javascript">//<![CDATA[ document.getElementById("user").focus();/* Must not include external javascript -jnk 06.20.09 *///]]></script></div></div><div id="bot-whm"></div>&copy; cPanel, Inc. 2009</div></body></html>] [expected_key=UYXIFBJaCFe8W7lUjcD7QZGgbg1S9cr_ghBdegnIOXPYcSIRmJNj3HQ7aabDYhUa]
    [check command:N/A][tcp connect:-]Restarting cpsrvd....
    system: /usr/local/cpanel/etc/init/stopstunnel
    system: /usr/local/cpanel/etc/init/stopcpsrvd
    system: /usr/local/cpanel/etc/init/startcpsrvd
    system: /usr/local/cpanel/etc/init/startstunnel
    ]...cpdavd [[check command:N/A][tcp connect:N/A]]...cpanellogd [[check command:+][tcp connect:N/A]]...clamd [[check command:+][tcp connect:N/A]]...Done
    Service Check Finished
     
  6. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Can you please tail the cPanel error log on restarting the chkservd again (or restart cPanel) and then provide those results?

    Code:
    tail -f /usr/local/cpanel/logs/error_log
    Thanks.
     
  7. Tymsah

    Tymsah Well-Known Member

    Joined:
    Apr 6, 2007
    Messages:
    151
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Hi,

    -- RESTART MARKER (PID 14070 at 1299016750)--
    Building global cache for cpanel...Done
    -- RESTART MARKER (PID 15441 at 1299017046)--
    Building global cache for cpanel...Done
    -- RESTART MARKER (PID 16000 at 1299017203)--
    Building global cache for cpanel...Done
    -- RESTART MARKER (PID 16681 at 1299017504)--
    Building global cache for cpanel...Done
    -- RESTART MARKER (PID 17229 at 1299017671)--
    Building global cache for cpanel...Done


    Regards
    Tymsah
     
  8. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Hello Tymsah,

    Without anything logging to the error log, this makes it difficult to know what is happening. Please open a ticket using the link in my signature or in WHM > Support Center > Contact cPanel area.

    Thanks!
     
  9. Tymsah

    Tymsah Well-Known Member

    Joined:
    Apr 6, 2007
    Messages:
    151
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Hi Tristan

    Ok.

    thank you for all

    Regards,
    Tymsah
     
  10. Tymsah

    Tymsah Well-Known Member

    Joined:
    Apr 6, 2007
    Messages:
    151
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Support Request Id 1255865
     
  11. cPanelJared

    cPanelJared Technical Analyst
    Staff Member

    Joined:
    Feb 25, 2010
    Messages:
    1,842
    Likes Received:
    18
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    I followed up on the ticket, and it appears that this problem was caused by ConfigServer (CSF) firewall rules that were not allowing chkservd, the cPanel service monitor, to check whether cPanel was running.
     

Share This Page