The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

_vti_bin/shtml.exe + ssl bug

Discussion in 'General Discussion' started by antodeepak, Feb 10, 2006.

  1. antodeepak

    antodeepak Active Member

    Joined:
    Jan 24, 2005
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    kerala, India
    Hello Buddies,

    I like to share a note regarding the issue with frontpage and ssl. With the new cpanel release the default permission of httpd.conf is 600. At certain times the we cannot access the emailforms with ssl on this permission and we will get a error saying that

    FrontPage Error.
    User: please report details to this site's webmaster.
    Webmaster: please see the server's system log for more details.

    The fix for this is very simple, just change the permission of httpd.conf to 644. You can better setup a cron job for this and also check with the script restartsrv_httpd and change the permission to 644 there.

    Keep enjoying with this thread. Please reply if this worked...

    With Regards,
     
  2. Jeffa

    Jeffa Member

    Joined:
    Jun 19, 2005
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    This did work for me, however I do not have SSL enabled...

    I use Centos 4.3

    -Jeffa
     
  3. rootsupport

    rootsupport Member

    Joined:
    May 2, 2006
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    Frontpage is installed on port 80, if you need frontpage to work with SSL you'll have to install frontpage on port 443. We manually copied the port 80 config over port 443 as one of the 443 one was missing some data

    root@server [/usr/local/frontpage]# cp www.domain.com:80.cnf www.domain.com:443.cnf
    cp: overwrite `www.domain.com:443.cnf'? y

    This worked for us perfectly. If anyone is facing this problem, do proceed on your own risk.
     
  4. WhatsYourDomain

    Joined:
    Mar 14, 2006
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    no luck

    I change httpd.conf too 644: no luck

    I cp'ed 80.crt to 443.crt: no luck

    Any other ideas?
     
  5. aboleth

    aboleth Well-Known Member

    Joined:
    Sep 8, 2005
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    6
    Another thing to remember. (I just had this problem). If the websites ssl cert is for domain.com and not www.domain.com then you will have to add domain.com:443.cnf as a copy of www.domain.com:443.cnf (or www.domain.com:80.cnf). This is what worked for me after trying the other suggestions in this post. Syntax below:

    root@server [/usr/local/frontpage]# cp www.domain.com:80.cnf domain.com:443.cnf

    Hope this helps,

    Nick
     
Loading...

Share This Page