The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

a 500 Internal Server Error error.

Discussion in 'General Discussion' started by surapong, Aug 18, 2009.

  1. surapong

    surapong Member

    Joined:
    Aug 18, 2009
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Hi All,

    Actually, php global register is set off by server manager, but my applications still need it. I try to turn it on by configuring .htaccess file which normally an added statement is "php_flag register_globals Off", and then i open the web page error shows me that

    "Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request. "

    My environment
    cPanel Version 11.24.5-STABLE
    PHP version 4.4.8
    MySQL version 4.1.22-standard
    cPanel Pro 1.0 (RC1)

    Please anyone suggest me on the problem.

    Best Regards,
    Surapong
     
  2. thewebhosting

    thewebhosting Well-Known Member

    Joined:
    May 9, 2008
    Messages:
    1,201
    Likes Received:
    1
    Trophy Points:
    38
    You can check the apache logs and provide us the exact error message. You can check the apache logs from the below mentioned location:

    /usr/local/apache/logs/error_log
     
  3. Sean.barron

    Sean.barron Active Member

    Joined:
    Aug 16, 2008
    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    6
    Most of the time this problem occurred when you upgrade cPanel version however, you can easily resolve this problem by following the below steps:-

    1)Check the permissions
    /usr/local/cpanel/3rdparty/bin/php
    /usr/local/cpanel/3rdparty/bin/php-cgi

    2) Both files should have 755 permissions.

    3) after the permission is changed run the below command from shell
    /scripts/makecpphp

    Done
     
  4. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Are you running PHP as SuPHP, DSO (Apache Module), FastCGI or CGI?

    As a side note, PHP 4.4.8 is a very old and EOL'd version of PHP. You may want to consider an upgrade to a newer version of PHP.
     
Loading...

Share This Page