a fatal error or timeout occurred while processing this directive

stianjaco

Registered
Oct 25, 2012
1
0
1
cPanel Access Level
Root Administrator
It all started when I tried to install FFMPEG (I used /http://linuxsysadminblog.com/2008/06/install-ffmpeg-ffmpeg-php-and-audio-binaries-on-centos-rhel-system-with-cpanel/ this tutorial but I changed some of the packages to newer versions. First I got a disk failure when trying to install ruby with the command "/scripts/installruby". Then my VPS Host when I clear the problem and I tried to continue. Got to the point in witch
I was suppose to install the ffpmeg-php. Everything seemed fine, but the phpinfo() did not show that the extension was installed. Tried to login to WHM to check there, and thats when all hell broke loose. After login to WHM all i get is a blank page with an error. Can't do anything. Tried to update and restart cpanel, no luck..
The error I get is:
Code:
not a reference at /usr/local/cpanel/Cpanel/CachedDataStore.pm line 165
	Carp::croak('not a reference') called at /usr/lib/perl5/site_perl/5.6.2/x86_64-linux/Storable.pm line 76
	Storable::logcroak('not a reference') called at /usr/lib/perl5/site_perl/5.6.2/x86_64-linux/Storable.pm line 303
	Storable::_store_fd('CODE(0x1a14c960)', 'pst0^E^H^C', 'GLOB(0x1a2de000)') called at /usr/lib/perl5/site_perl/5.6.2/x86_64-linux/Storable.pm line 295
	Storable::nstore_fd('pst0^E^H^C', 'GLOB(0x1a2de000)') called at /usr/local/cpanel/Cpanel/CachedDataStore.pm line 165
	Cpanel::CachedDataStore::loaddatastore('/var/cpanel/pluginscache.yaml', 0, 'HASH(0x1a2dde10)') called at /usr/local/cpanel/Cpanel/CachedDataStore.pm line 37
	Cpanel::CachedDataStore::load_ref('/var/cpanel/pluginscache.yaml', 'HASH(0x1a2dde10)') called at /usr/local/cpanel/Cpanel/CachedDataStore.pm line 27
	Cpanel::CachedDataStore::fetch_ref('/var/cpanel/pluginscache.yaml') called at whostmgr/bin/whostmgr10 line 658
	main::_plugins_data() called at whostmgr/bin/whostmgr10 line 605
	main::_init_whm_template_required_variable('addons', 'HASH(0xea8060)') called at whostmgr/bin/whostmgr10 line 516
	main::themecommand() called at whostmgr/bin/whostmgr10 line 223
I'm using CentOS 5.7

Btw. Is there a better way to get ffmpeg (with the php extension) to work with cpanel, maybe a newer tutorial?
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
40
248
somewhere over the rainbow
cPanel Access Level
Root Administrator
Is that the entire error message? Do you see anything else when tailing /usr/local/cpanel/logs/error_log in root SSH upon loading up WHM?

Also, of note, we do not support FFMPEG questions on the forums. This is for legal reasons. It would be highly advisable to direct questions to some online FFMPEG forum instead.