The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

a fatal error or timeout occurred while processing this directive

Discussion in 'General Discussion' started by ADresch, Jan 5, 2006.

  1. ADresch

    ADresch Registered

    Joined:
    Nov 25, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Hello all

    I noticed today that when I access my CPanel account for my domain, I get this message at the top

    "[a fatal error or timeout occurred while processing this directive]"

    The page stops loading and all I get is

    General account information:

    Hosting package Default


    No other details or buttons show up

    I tried restarting Cpanel, tried updating with no joy
    Any help is appreciated.
     
  2. lostinspace

    lostinspace Well-Known Member

    Joined:
    Jul 19, 2003
    Messages:
    122
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Colorado Springs, CO
    Same thing here ont he latest release build...
     
  3. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    When you get that error you should check in /usr/local/cpanel/logs/error_log as it ought to provide more detailed information about the cause.
     
  4. DaiTengu

    DaiTengu Member

    Joined:
    Nov 1, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    It seems a lot of people are having this problem, it does not exist in the "Stable" build.

    I had to downgrade to "Stable" (S31) in order to 'resolve' this issue.


    The error I have in error_log is:

    Working ifconfig required to determine IP. at cpanel.pl line 3026
    (internal death) Thu Jan 5 12:35:53 2006 [20731] error: Working ifconfig required to determine IP. at cpanel.pl line 3026


    ifconfig works fine for me.


    Running: redhat ES 3 (up2date is current) MySQL 4.1, Apache 1.3.34, PHP 5.0.5
     
  5. lostinspace

    lostinspace Well-Known Member

    Joined:
    Jul 19, 2003
    Messages:
    122
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Colorado Springs, CO
    Yep, confirmed on all servers with release build.

    Same error in cpanel log.
     
  6. lostinspace

    lostinspace Well-Known Member

    Joined:
    Jul 19, 2003
    Messages:
    122
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Colorado Springs, CO
    ifconfig had perms 550.

    Changed perms to 555 and cpanel works again.
     
    #6 lostinspace, Jan 5, 2006
    Last edited: Jan 5, 2006
  7. ADresch

    ADresch Registered

    Joined:
    Nov 25, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Hmm where is that file stored? I couldn't find it
     
  8. DaiTengu

    DaiTengu Member

    Joined:
    Nov 1, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    ifconfig should be in /sbin

    SSH into your machine and type:

    chmod 555 /sbin/ifconfig
     
  9. ADresch

    ADresch Registered

    Joined:
    Nov 25, 2005
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    That worked, many thanks

    Heh, I was searching for iPconfig, not iFconfig :P
     
  10. DaiTengu

    DaiTengu Member

    Joined:
    Nov 1, 2005
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    someone spends too much time in windows! :)
     
  11. thewishbone

    thewishbone Active Member

    Joined:
    Aug 7, 2005
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Please i have this trouble in my logs?



    Internal Error: "" Normal Connection Timeout (Probably closed browser on a HTTP/1.1 session) at cpsrvd.pl line 1470.
    Content-type: text/html

    Internal Error: "" Normal Connection Timeout (Probably closed browser on a HTTP/1.1 session) at cpsrvd.pl line 1470.
    Content-type: text/html

    Internal Error: "" Normal Connection Timeout (Probably closed browser on a HTTP/1.1 session) at cpsrvd.pl line 1470.
    Content-type: text/html

    Internal Error: "" Normal Connection Timeout (Probably closed browser on a HTTP/1.1 session) at cpsrvd.pl line 1470.
    Content-type: text/html



    What i can do?????? Thanks is urgent!
     
  12. Murtaza_t

    Murtaza_t Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    476
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    cPanel Access Level:
    Website Owner
    They say nothing... you should check the error_log at the time when you get that error.. you can use this command on shell and then generate the error in Cpanel :

    tail -f /usr/local/cpanel/logs/error_log
     
  13. DeepXP

    DeepXP Well-Known Member

    Joined:
    Feb 20, 2005
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Internet
    cPanel Access Level:
    Root Administrator
    Yup same error in mine to...
    I am running latest edge build...its 10.8.1-EDGE 103

    I guess this has to do with some bug in cpanel...

    Deep
     
  14. Bartje

    Bartje Registered

    Joined:
    Jan 21, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    (internal warning) Wed Jan 11 13:21:58 2006 [15299] warn: Error opening /etc/cpbackup.conf: Permission denied at /usr/local/cpanel/Cpanel/Quota.pm line 43, <LANGFD> line 633.
    Cpanel::Quota::displayquota() called at /usr/local/cpanel/Cpanel/Quota.pm line 130
    Cpanel::Quota::Quota_showquotaremain() called at (eval 25) line 1
    eval 'Quota_showquotaremain(@RARGS);' called at cpanel.pl line 605
    main::exectag('<cpanel Quota="showquotaremain()">') called at cpanel.pl line 3539
    main::dotag(undef) called at cpanel.pl line 3430
    main::parsehtml('GLOB(0xa5f7960)') called at cpanel.pl line 329

    Im getting this in the error_log
     
  15. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    3
    Trophy Points:
    18
  16. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    3
    Trophy Points:
    18
  17. tom_taylor

    tom_taylor Active Member

    Joined:
    Nov 30, 2005
    Messages:
    34
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Warrington, UK
    Gotta be something wrong with the release, since 105 came out many problems have turned up :(
     
  18. verdon

    verdon Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    836
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Northern Ontario, Canada
    cPanel Access Level:
    Root Administrator
    Yes, problems while creating email accounts in cpanel too
     
  19. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    3
    Trophy Points:
    18
    I'm looking into it and have found the issue with the cpbackup file, a pacth has been created and should be released soon that will resolve it for everyone.

    Probably should chmod it back to 600 ASAP since that protects your FTP login info.

    The error is spurious and can be ignored, its just annoying currently :)
     
  20. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    3
    Trophy Points:
    18

    Does that mean that you get the "a fatal error" message when creating accounts and that the erro_log shows the permission denied message?

    If so the previous applies to this as well, if not you may want to open a new threads with more details of the problem or a ticket.
     
Loading...

Share This Page