Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

[a fatal error or timeout occurred while processing this directive]

Discussion in 'General Discussion' started by user2006, Oct 1, 2006.

  1. user2006

    user2006 Member

    Joined:
    May 23, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    151
    WHM 10.8.0
    Cpanel 10.9.0-R34
    RedHat Enterprise 3 i686

    When using file manager to edit files in the public_html directory my clients are receiving the error message below. This message only occurs under the public_html directory and not in the root directory of the clients. The public_html directory is set to 777. Any help would be appreciated.

    /path/to/file/filename.html File Saved
    [a fatal error or timeout occurred while processing this directive]

    Thanks.
     
  2. PWSowner

    PWSowner Well-Known Member

    Joined:
    Nov 10, 2001
    Messages:
    2,948
    Likes Received:
    4
    Trophy Points:
    343
    Location:
    ON, Canada
    This probably won't make a difference, but the public_html directory should be 750 not 777. The www would be 777 since it's actually a symbolic link.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. user2006

    user2006 Member

    Joined:
    May 23, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    151
    Thanks PWSowner. I'll make that change.
     
  4. shashank

    shashank Well-Known Member
    PartnerNOC

    Joined:
    Apr 12, 2003
    Messages:
    159
    Likes Received:
    1
    Trophy Points:
    168
    cPanel Access Level:
    Root Administrator
    The file they are trying to edit is probably nobody owned. Check the file ownership as well.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. angelina_holy

    angelina_holy Well-Known Member

    Joined:
    Aug 6, 2006
    Messages:
    113
    Likes Received:
    0
    Trophy Points:
    166
    The ownership of public_html must be user :user and permission must be 755 .

    chmod 755 public_html
     
  6. user2006

    user2006 Member

    Joined:
    May 23, 2006
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    151
    Thank you very much angelina_holy & shashank. You were both correct. File Manager works fine now.

    Thanks again.
     
  7. dgbaker

    dgbaker Well-Known Member
    PartnerNOC

    Joined:
    Sep 20, 2002
    Messages:
    2,574
    Likes Received:
    3
    Trophy Points:
    343
    Location:
    Toronto, Ontario Canada
    cPanel Access Level:
    DataCenter Provider
    Actually that is incorrect. The proper setting is as follows

    userid:nobody
    750
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    4
    Trophy Points:
    193
    Location:
    Minneapolis, MN
    I agree with you. That's the correct setting for public_html directory.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    22
    Trophy Points:
    463
    Location:
    Go on, have a guess
    I agree with david too :eek:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  10. PWSowner

    PWSowner Well-Known Member

    Joined:
    Nov 10, 2001
    Messages:
    2,948
    Likes Received:
    4
    Trophy Points:
    343
    Location:
    ON, Canada
    4 of the most active posters here can't all be wrong. ;)

    CPanel changed the group and permissions quite a while ago. If owner of username and group of nobody with permissions of 750 doesn't let you save the file, something else is wrong.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice