The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A localdomains bug for WHM.

Discussion in 'General Discussion' started by mycuteoo, May 12, 2008.

Thread Status:
Not open for further replies.
  1. mycuteoo

    mycuteoo Active Member

    Joined:
    Oct 24, 2006
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Hi~

    My version of WHM/cPanel is "WHM 11.23.0 cPanel 11.23.1-C24255
    CENTOS Enterprise 5 x86_64 on standard - WHM X v3.1.0".

    Lately, I try copy an account from another server to my server that all OK but the file /etc/localdomains is not update.

    So it have some error messages that like "lowest numbered MX record points to local host" in /var/log/exim_mainlog.

    I tried a force cpanel update and that didn't fix the issue.

    Please tell me how to fix it...:(
     
  2. brianoz

    brianoz Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,146
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    Melbourne, Australia
    cPanel Access Level:
    Root Administrator
    I suspect, and from memory, that error is produced when the account is NOT in /etc/localdomains but the MX record(s) for the domain point to this machine.

    Is the domain in /etc/localdomains? If not, try adding it there.
     
  3. mycuteoo

    mycuteoo Active Member

    Joined:
    Oct 24, 2006
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Try to call off "Tweak Settings > Automatically setup /etc/localdomains, /etc/remotedomains, /etc/secondarymx based on where the mx entry is pointed." function in WHM is OK.

    ^O^
     
  4. brianoz

    brianoz Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,146
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    Melbourne, Australia
    cPanel Access Level:
    Root Administrator
    What did that actually mean? :confused:
     
  5. ghanahost

    ghanahost Member

    Joined:
    Apr 9, 2008
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Accra
    in WHM, click on tweak settings and follow in the order given
     
  6. mesranet

    mesranet Well-Known Member

    Joined:
    May 6, 2002
    Messages:
    126
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    This issue are not being fix even the latest WHM 11.23.0 cPanel 11.23.1-C24654 and by default WHM will enable the "Automatically setup /etc/localdomains, /etc/remotedomains, /etc/secondarymx based on where the mx entry is pointed."
     
  7. natong

    natong Well-Known Member

    Joined:
    May 17, 2008
    Messages:
    85
    Likes Received:
    0
    Trophy Points:
    6
    I faced this problem too. so bad.

    The default is enable auto fix but it never fix.

    try
    /scripts/updateuserdomains

    or manual edit

    /etc/localdomains
    /etc/remotedomains
    /etc/secondarymx
     
  8. jespinal

    jespinal Registered

    Joined:
    May 8, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    To solve this problem, please use the following commands

    /scripts/mailperm --force
    /scripts/updateuserdomains

    After that, take a look if your /etc/localdomains is in order.

    This problem has been addressed in the latest 'Edge' build , but this may take some days to appear in the stable branch.




    --
    Jose P. Espinal
    http://www.slackware-es.com
     
  9. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    This is caused by cPanel/WHM detecting the dns is off server and putting the domain in /etc/remotedomains. This was done to resolve some complaints about the way this system operated. The behavior will be changed in 11.23.2 (coming this week if all goes well) to always assume the account is local when it is created or transfered in as this behavior has been problematic and the original behavior, while not perfect is much more desirable for most.

    Disabling "Tweak Settings > Automatically setup /etc/localdomains, /etc/remotedomains, /etc/secondarymx based on where the mx entry is pointed." is currently the best work around.

    If you have a domain with the problem you can resolve it by editing it in the mx entry editor and saving it once the dns is pointed at the server (or you can choose always accept if its not).
     
  10. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    I'll try to work up a quick script to force a domain to be local.
     
  11. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
  12. verdon

    verdon Well-Known Member

    Joined:
    Nov 1, 2003
    Messages:
    836
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    Northern Ontario, Canada
    cPanel Access Level:
    Root Administrator
    Can't you just cut from /etc/remotedomains and paste to /etc/localdomains ?
     
  13. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Yes, just be sure to remove from /etc/secondarymx as well (although it doesn't really matter if its in localdomains)
     
  14. VeZoZ

    VeZoZ Well-Known Member

    Joined:
    Dec 14, 2002
    Messages:
    248
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    DataCenter Provider
    I've ended up having to go through every machine and turn this feature off since it is causing nothing but problems.

    At least I know what was causing this issue at least and was able to turn it off.
     
    #14 VeZoZ, Jun 2, 2008
    Last edited: Jun 2, 2008
  15. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    This behavior has been reverted in all of yesterdays builds.
     
  16. scottc

    scottc Well-Known Member

    Joined:
    Apr 21, 2002
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    I assume that "reverted" means that the behavior going forward changes, but it doesn't fix the domains that WHM set up incorrectly before yesterday? We just lost a new client because all of her mail was rejected by our server, and unfortunately she canceled without giving us a chance to discover the bug and correct it.
     
  17. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Just open the domain up in the mx entry editor and save it (if the dns does not yet point to the server, click always accept).
     
  18. scottc

    scottc Well-Known Member

    Joined:
    Apr 21, 2002
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    I know how to fix it once the problem is identified...I was hoping that maybe the bug fix would correct the ones that had been set up wrong too. I guess we'll have to compare a list of domains on a server to the localdomains file, server by server, to find them all.
     
  19. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Closing this thread as further discussion should take place here:

    http://forums.cpanel.net/showthread.php?t=81725
     
Loading...
Thread Status:
Not open for further replies.

Share This Page