A problem after upgrading databases in a vps server

syriasea

Registered
Apr 28, 2018
3
1
3
Syria
cPanel Access Level
Root Administrator
Hello..
I upgraded databases from version 5.6 to version 5.7 via the whm control panel ...
But I got a problem which is .. when I send any message through whmcs or enter technical support or purchase plans .. it gives me the following error
HTTP ERROR 500
Note that I rebuilt the Apache after updating the databases, but the error remains of no use ...
When I make sql_mode empty by command
SET @@ global.sql_mode = '';
The site works well ...
But when i start mysql restart ... the error is due to the site ...
Likewise, when I create a database to install any software ... it gives an error that cannot connect to the databases
Is there any benefit? ?
 

ffeingol

Well-Known Member
PartnerNOC
Nov 9, 2001
621
202
343
cPanel Access Level
DataCenter Provider
Between MySQL V5.5 and 5.7 MySQL started enforcing "strict mode". That may cause some SQL to fail.

You can set the sql_mode = "" in /etc/my.cnf by adding:

sql_mode=""

Or updating it if the sql_mode already exists in your my.cnf.

Once you have made the change to /etc/my.conf (I'd suggest backing up the file before modifying it), you'll need to restart MySQL.
 
  • Like
Reactions: syriasea

syriasea

Registered
Apr 28, 2018
3
1
3
Syria
cPanel Access Level
Root Administrator
Between MySQL V5.5 and 5.7 MySQL started enforcing "strict mode". That may cause some SQL to fail.

You can set the sql_mode = "" in /etc/my.cnf by adding:

sql_mode=""

Or updating it if the sql_mode already exists in your my.cnf.

Once you have made the change to /etc/my.conf (I'd suggest backing up the file before modifying it), you'll need to restart MySQL.
Thank you ..
I added sql_mode = "" "
And it has been updated ..
And now it works fine
 
  • Like
Reactions: cPanelLauren