The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A really bizzarre stuff when I try create a account

Discussion in 'General Discussion' started by Fabio.LS, May 27, 2010.

  1. Fabio.LS

    Fabio.LS Registered

    Dec 3, 2009
    Likes Received:
    Trophy Points:
    Hello friends! :D
    Let's see who can help me.

    I have a VPS with cPanel 11.25.0-R45750 - WHM 11.25.0 - X 3.9 CENTOS 5.5 x86_64 virtuozzo.

    When I try create a new domain account, everything runs fine. But nothing works.

    The new domain account is created with root user permission. The /home/<user> folder don't receives the structure, and in the List Account, the account don't receives a IP.

    I tried run:
    - easy apache
    - /scrips/upcp --force (a lot of times)
    - /scripts/chownpublichtmls
    - /etc/init.d/cpanel restart
    - /scripts/rebuildnamedconf

    Please take a look in the images (attachment)

    the file /usr/local/cpanel/logs/error_log shows:
    Creating mailbox file: File exists
    useradd: warning: the home directory already exists.
    Not copying any file from skel directory into it.:eek:
    tar: ./public_html: Cannot mkdir: Permission denied
    tar: ./public_ftp: Cannot mkdir: Permission denied
    tar: .: Cannot utime: Operation not permitted
    tar: .: Cannot change mode to rwxr-xr-x: Operation not permitted
    tar: Error exit delayed from previous errors
    [2010-05-27 21:57:25 -0300] warn [whostmgr5] Failed to set ownership on user directory in cpanel userdata at /usr/local/cpanel/Cpanel/Config/ line 688
    Cpanel::Config::userdata::save_userdata('a1a1a1te', 'main', HASH(0x204d0720)) called at /usr/local/cpanel/Cpanel/Config/ line 723
    Cpanel::Config::userdata::save_userdata_main('a1a1a1te', HASH(0x204d0720)) called at /usr/local/cpanel/Whostmgr/Accounts/ line 862
    Whostmgr::Accounts::Create::_wwwacct('plan', 'default', 'maxpark', 'unlimited', 'hasshell', 'n', 'maxlst', 'n', 'maxpop', 'n', 'maxaddon', 'unlimited', 'cpmod', 'x3', 'pass', '&BU=JWrOE.Un', 'force', undef, 'maxsub', 'n', 'domain', '', 'maxsql', 'n', 'quota', 0, 'installfp', 'n', 'maxftp', 'n', 'mxcheck', 'local', 'locale', 'pt_br', 'contactemail', '', 'hascgi', 'y', 'user', 'a1a1a1te', 'useip', 'n', 'useregns', 0, 'bwlimit', 0, 'forcedns', 0, 'owner', 'root', 'is_restore', 0, 'featurelist', 'default') called at /usr/local/cpanel/Whostmgr/Accounts/ line 1705
    Whostmgr::Accounts::Create::_createaccount('customip', '--Auto Assign--', 'plan', 'default', 'language', 'pt_br', 'maxpark', 'unlimited', 'password', '&BU=JWrOE.Un', 'maxlst', 'unlimited', 'maxpop', 'unlimited', 'maxaddon', 'unlimited', 'pkgname', '', 'cpmod', 'x3', 'cgi', 1, 'maxsub', 'unlimited', 'domain', '', 'maxsql', 'unlimited', 'hasuseregns', 1, 'sign', '', 'quota', 'unlimited', 'mxcheck', 'local', 'maxftp', 'unlimited', 'contactemail', '', 'username', 'a1a1a1te', 'bwlimit', 'unlimited', 'featurelist', 'default') called at whostmgr/bin/whostmgr5 line 629
    main::wwwacct() called at whostmgr/bin/whostmgr5 line 210

    Attached Files:

  2. JawadArshad

    JawadArshad Well-Known Member

    Apr 8, 2008
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    DataCenter Provider
    Posting to help others facing this.

    Not sure if OP's issue was resolved. I got the same error on a VPS where diskspace and inodes were OK but quotaugidlimit apparently expired. Increasing quotaugidlimit resolved the issue.
    Note: This limit can be increased at hardware node level and if you only have VPS access, you need to ask your host to increase this limit for you.

Share This Page