Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A Record Issue

Discussion in 'Bind / DNS / Nameserver Issues' started by alan_76, Sep 7, 2017.

  1. alan_76

    alan_76 Registered

    Joined:
    Sep 5, 2017
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Aberdeen
    cPanel Access Level:
    Website Owner
    Hi,

    I want to point the A record of my site to a new location. I changed the A record in the DNS records. That pointed the site to my new site. However the email stopped working. I switched the number back to the previous number and added a new A record to point to the new site. The email was working a the site did point to the new site. However without changing anything the site has reverted to the previous site.

    I suspect it's because of the following detials
    Code:
    example.com. 900 IN A 23.235.xxx.xxx Edit Delete
    mail.example.com. 900 IN CNAME example.com Edit Delete
    www.example.com. 900 IN CNAME example.com 
    
     
    #1 alan_76, Sep 7, 2017
    Last edited by a moderator: Sep 7, 2017
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,220
    Likes Received:
    1,376
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    You can setup a new "A" record for an entry such as "mailserver.example.tld" pointing to the cPanel server's IP address, and then modify the "mail" CNAME so it points to "mailserver.example.tld". Then, update the "A" record for "example.com" to the IP address of your preference.

    Thank you.
     
  3. alan_76

    alan_76 Registered

    Joined:
    Sep 5, 2017
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Aberdeen
    cPanel Access Level:
    Website Owner

    Thanks Michael,

    I've changed the setting as above. The A record works fine pointing to the site. I can send emails out from my account but it's not receiving emails just now.

    Thanks again
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,220
    Likes Received:
    1,376
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Can you report this issue to your web hosting provider so they can take a closer look to see why incoming email isn't working?

    Thank you.
     
Loading...

Share This Page