The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A Strange Problem (httpd.conf)

Discussion in 'General Discussion' started by checked, Oct 22, 2004.

  1. checked

    checked Well-Known Member

    Joined:
    May 3, 2004
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    A Strange Problem - httpd.conf is automatically modifying

    I'm having a Linux Redhat 9.0 with cPanel/WHM (WHM 9.4.0 cPanel 9.4.1-S65). I have few accounts on my server excluded from safe mode restriction by adding few lines under the httpd.conf.

    The problem is that after few days my httpd.conf automatically get modified and those safe mode exclusion line automatically get removed from httpd.conf. It happens after within few days whenevr I add those lines under the httpd.conf.

    Now I'm getting sick of changing again and again httpd.conf. Please help me and suggest me that what can cause this strange problem.
     
    #1 checked, Oct 22, 2004
    Last edited: Oct 22, 2004
  2. checked

    checked Well-Known Member

    Joined:
    May 3, 2004
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    Cmon guys atleast someone should know about this :(
     
  3. checked

    checked Well-Known Member

    Joined:
    May 3, 2004
    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    6
    bump

    Please
     
  4. l3ean

    l3ean Registered

    Joined:
    Nov 23, 2004
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    If it makes you feel any better at least your whm is editing it correctly. Look at one of my dedicated client's httpd.conf file after he adds or changes domains or ip addresses.

    What's wrong with that??? :mad: Seems to me whm don't know what 1 + 1 is to put the virtualhosts in order.
     
  5. blweb

    blweb Active Member

    Joined:
    Oct 1, 2004
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    I am having the NameVirtualHost problem too.

    My httpd.conf is a MESS since we updated. Basically, it seems that random NameVirtualHost directives are being entered with random IP's.

    This shows up TWICE in the conf file:
    Code:
    NameVirtualHost 28.119.84.140:80
    
    ErrorDocument 400 /400.shtml
    ErrorDocument 401 /401.shtml
    ErrorDocument 403 /403.shtml
    ErrorDocument 404 /404.shtml
    ErrorDocument 500 /500.shtml
    ScriptAlias /cgi-sys/ /usr/local/cpanel/cgi-sys/
    Alias /sys_cpanel/ /usr/local/cpanel/sys_cpanel/
    Alias /java-sys/ /usr/local/cpanel/java-sys/
    Alias /img-sys/ /usr/local/cpanel/img-sys/
    Alias /akopia/ /usr/local/cpanel/3rdparty/interchange/share/akopia/
    Alias /neo-images/ /usr/local/cpanel/base/neomail/neo-images/
    ScriptAliasMatch ^/cpanel/(.*) /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /cpanel /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /whm /usr/local/cpanel/cgi-sys/whmredirect.cgi
    ScriptAlias /securewhm /usr/local/cpanel/cgi-sys/swhmredirect.cgi
    ScriptAlias /webmail /usr/local/cpanel/cgi-sys/wredirect.cgi
    ScriptAliasMatch ^/webmail/(.*) /usr/local/cpanel/cgi-sys/wredirect.cgi
    ScriptAliasMatch ^/kpanel/(.*) /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /controlpanel /usr/local/cpanel/cgi-sys/redirect.cgi
    ScriptAlias /securecontrolpanel /usr/local/cpanel/cgi-sys/sredirect.cgi
    Alias /mailman/archives/ /usr/local/cpanel/3rdparty/mailman/archives/public/
    ScriptAlias /mailman/ /usr/local/cpanel/3rdparty/mailman/cgi-bin/
    Alias /pipermail/ /usr/local/cpanel/3rdparty/mailman/archives/public/
    Alias /interchange/ /usr/local/cpanel/3rdparty/interchange/share/interchange/
    Alias /interchange-5/ /usr/local/cpanel/3rdparty/interchange/share/interchange-5/
    Then there is wierness like this:
    Code:
    NameVirtualHost 28.119.84.144:80
    
    <VirtualHost 28.119.84.142>
    ServerAlias www.antonecabinets.com antonecabinets.com
    ServerAdmin webmaster@antonecabinets.com
    DocumentRoot /home/antoneca/public_html
    <IfModule mod_php4.c>
    php_admin_value open_basedir "/home/antoneca/:/usr/lib/php:/usr/local/lib/php:/tmp"
    </IfModule>
    <IfModule mod_userdir.c>
    UserDir disabled
    UserDir enabled antoneca 
    </IfModule>
    ServerName www.antonecabinets.com
    User antoneca
    Group antoneca
    CustomLog domlogs/antonecabinets.com combined
    ScriptAlias /cgi-bin/ /home/antoneca/public_html/cgi-bin/
    </VirtualHost>
    
    
    NameVirtualHost 28.119.84.143:80
    
    <VirtualHost 28.119.84.142>
    ServerAlias www.filmisland.co.uk filmisland.co.uk
    ServerAdmin webmaster@filmisland.co.uk
    DocumentRoot /home/ashley/public_html
    <IfModule mod_php4.c>
    php_admin_value open_basedir "/home/ashley/:/usr/lib/php:/usr/local/lib/php:/tmp"
    </IfModule>
    <IfModule mod_userdir.c>
    UserDir disabled
    UserDir enabled ashley 
    </IfModule>
    ServerName www.filmisland.co.uk
    User ashley
    Group ashley
    CustomLog domlogs/filmisland.co.uk combined
    ScriptAlias /cgi-bin/ /home/ashley/public_html/cgi-bin/
    </VirtualHost>
    
    
    <VirtualHost 28.119.84.145>
    ServerAlias www.stoctech.co.uk stoctech.co.uk
    ServerAdmin webmaster@stoctech.co.uk
    DocumentRoot /home/atko64/public_html
    <IfModule mod_php4.c>
    php_admin_value open_basedir "/home/atko64/:/usr/lib/php:/usr/local/lib/php:/tmp"
    </IfModule>
    <IfModule mod_userdir.c>
    UserDir disabled
    UserDir enabled atko64 
    </IfModule>
    ServerName www.stoctech.co.uk
    User atko64
    Group atko64
    CustomLog domlogs/stoctech.co.uk combined
    ScriptAlias /cgi-bin/ /home/atko64/public_html/cgi-bin/
    </VirtualHost>
    
    
    NameVirtualHost 28.119.84.142:80
    
    <VirtualHost 28.119.84.142>
    ServerAlias www.bbclemens.com bbclemens.com
    ServerAdmin webmaster@bbclemens.com
    DocumentRoot /home/bclemens/public_html
    <IfModule mod_php4.c>
    php_admin_value open_basedir "/home/bclemens/:/usr/lib/php:/usr/local/lib/php:/tmp"
    </IfModule>
    <IfModule mod_userdir.c>
    UserDir disabled
    UserDir enabled bclemens 
    </IfModule>
    ServerName www.bbclemens.com
    User bclemens
    Group bclemens
    CustomLog domlogs/bbclemens.com combined
    ScriptAlias /cgi-bin/ /home/bclemens/public_html/cgi-bin/
    </VirtualHost>
    Does anybody know what is causing this - or how to fix it? Should I just edit my httpdconf file and thing will append to the end?

    We have another box with an older version of cpanel and the virtual host directives don't have the IP in them. They have the domain name. For example:
    Code:
    <VirtualHost beavercreekranch.ca>
    ServerAlias  beavercreekranch.ca
    ServerName beavercreekranch.ca
    ScriptAlias /cgi-bin /home/clients/beavercreekranch.ca/cgi-bin
    DocumentRoot /home/clients/beavercreekranch.ca/html
    ErrorLog /home/clients/beavercreekranch.ca/logs/error.log
    CustomLog /home/clients/beavercreekranch.ca/logs/access.log "%h %l %u %t \"%r\" %s %b \"%{Referer}i\"\"%{User-agent}i\""
    </VirtualHost>
    PLEEEEEEEEEEEASE help.
     
  6. flash7

    flash7 Well-Known Member

    Joined:
    Feb 16, 2004
    Messages:
    203
    Likes Received:
    0
    Trophy Points:
    16
    Same problem here: cPanel 10.0.0-R146

    some shared sites point to my home directory


    WELCOME TO CPANEL!!!!!!!!! :D
     
Loading...

Share This Page