The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Aaahhh! No Email!!!! Exim Issue?!

Discussion in 'E-mail Discussions' started by Krownet, Jul 13, 2006.

  1. Krownet

    Krownet Active Member

    Joined:
    Sep 16, 2005
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    Hi,

    This just suddenly happened for my email about 2 weeks ago. It started that I could not send any email. No email at all could be sent, I was still receiving email however.

    Last week, my server stopped receiving email all together. I've read on the internet on how to fix this. At the same time PHP stopped being able to use fopen and fgetcontent to view remote domains.

    I have already solved the PHP problem, by editing resolv.conf.

    Now the only problem that remains is this darn email thing. It just came out of nowhere, and now I no longer receive any emails for ANY domain (I only have 12 on my server. This server is strictly being run for my web network). When I send an email, I get a Mail Delivery Error Notice, with this being said:

    It isnt just the emails that I'm sending it to, because it happens to any domain which I send an email too. When receiving emails. They are delivered sometimes (some mail servers return a Mail Delivery Notice, other's dont return anything. I've tried from multiple accounts). So I have no idea where most of the emails are going.

    Anyone have any idea on what is going on, and how I can fix it? I thought it was a resolving error at first, and it still may be, but my resolv.conf is set properly.

    Thanks for reading this, and I hope that someone has an idea on how to fix this :)

    Cheers,
    -Brian :cool:
     
    #1 Krownet, Jul 13, 2006
    Last edited: Jul 13, 2006
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    1. Make sure named is running on the server if it is meant to be

    2. tail /var/log/exim_mainlog and then send in an email and watch what happens
     
  3. Krownet

    Krownet Active Member

    Joined:
    Sep 16, 2005
    Messages:
    38
    Likes Received:
    0
    Trophy Points:
    6
    --- Problem Solved ---

    Issue was the datacenter's DNS. They had changed them, and I guess I slipped off that notification list somehow :P

    Problem lay in incorrect resolv.conf settings.

    Thanks for your help guys .. sorry for waisting your time :eek:

    Cheers,
    -Brian
     
Loading...

Share This Page