Able To Recieve Emails, Not Receive VPS

hoboman24

Registered
Feb 5, 2013
4
0
1
cPanel Access Level
Root Administrator
Got a new VPS, updated domain information to point to VPS, add an account with domain, set up email account Logged into Cpanel and tried to send a test email to both a gmail and hotmail account and neither were received, sent an email to own email [email protected]domain.com and gets sent to me successfully.

Why won't the messages get sent to providers like gmail, hotmail,yahoo etc?
Everything on intodns is green

Oh I mean, I am not able to send emails, only able to receive them. Messed up on that title
 
Last edited:

max_payne

Active Member
Feb 1, 2013
33
1
6
cPanel Access Level
Root Administrator
Check your mail logs to see what the errors say when sending to gmail, hotmail or yahoo. If you have a VPS you should be able to run the following as the root user via SSH:

tail -f /var/log/exim_mainlog | exigrep [email protected]

Send a test email from an address on your server to the gmail account and check to see if you see any errors. tail -f flag means you are viewing the logs live. The exigrep command means the log output will only display information for [email protected].

Have you checked the spam folders to see if anything is being delivered there? Enable SPF and DKIM as a start.
 

hoboman24

Registered
Feb 5, 2013
4
0
1
cPanel Access Level
Root Administrator
Check your mail logs to see what the errors say when sending to gmail, hotmail or yahoo. If you have a VPS you should be able to run the following as the root user via SSH:

tail -f /var/log/exim_mainlog | exigrep [email protected]

Send a test email from an address on your server to the gmail account and check to see if you see any errors. tail -f flag means you are viewing the logs live. The exigrep command means the log output will only display information for [email protected].

Have you checked the spam folders to see if anything is being delivered there? Enable SPF and DKIM as a start.
Tried the command through putty, seems like it froze, Ill leave it running just in case.
I have enabled both just now and receive these messages for both DKIM and SPF

Status: Enabled Warning: cPanel is unable to verify that this server is an authoritative nameserver for mydomain.com [?] DKIM
Status: Enabled Warning: cPanel is unable to verify that this server is an authoritative nameserver for mydomain.com [?] SPF

That may have something to do with it...hmm...
 

max_payne

Active Member
Feb 1, 2013
33
1
6
cPanel Access Level
Root Administrator
It looks like you are using custom nameservers instead of private nameservers. Enabling SPF and DKIM in cPanel will not do anything unless you are using your own private nameservers. DKIM and SPF are merely DNS entries which need to be added to your live DNS zone file- wherever that may be.

The strange part is that you are saying that running a DNS report on intodns.com shows everything set up properly. Check the MX section in the DNS report to see if it is set to the proper place.

Also, running the command should not freeze unless there is something wrong with the server or what you see as 'freezing' may mean the server is not generating any logs when sending to [email protected]. Are you using webmail to test this or some kind of email client? Try with webmail if you haven't. Also try the following command instead if the gmail one continues to not generate any logs:

tail -f /var/log/exim_mainlog | exigrep [email protected]

m[email protected] obviously being the email account on your VPS.
 

hoboman24

Registered
Feb 5, 2013
4
0
1
cPanel Access Level
Root Administrator
It looks like you are using custom nameservers instead of private nameservers. Enabling SPF and DKIM in cPanel will not do anything unless you are using your own private nameservers. DKIM and SPF are merely DNS entries which need to be added to your live DNS zone file- wherever that may be.

The strange part is that you are saying that running a DNS report on intodns.com shows everything set up properly. Check the MX section in the DNS report to see if it is set to the proper place.

Also, running the command should not freeze unless there is something wrong with the server or what you see as 'freezing' may mean the server is not generating any logs when sending to [email protected]. Are you using webmail to test this or some kind of email client? Try with webmail if you haven't. Also try the following command instead if the gmail one continues to not generate any logs:

tail -f /var/log/exim_mainlog | exigrep [email protected]

[email protected] obviously being the email account on your VPS.
Seem to have gotten it all straightened out. There was an ip that shouldn't belong being related with the nameservers. I am able to send messages out now. And have DKIM and SPF enabled correctly as well.

However, after logging into my email that receives server error messages, I have been receiving emails with the subject: Cron Daemon
and says..

Error: Unable to read database "/var/lib/vnstat/eth0".
Error: Unable to get interface "eth0" statistics.
Error: Interface "eth0" couldn't be found.
Only available interfaces can be added for monitoring.

The following interfaces are currently available:
lo venet0
---

Any ideas with this? I have about 300 emails of this haha
 

max_payne

Active Member
Feb 1, 2013
33
1
6
cPanel Access Level
Root Administrator
Glad you were able to fix the problem. As for the emails you are receiving, I am not certain about this but you may be able to fix it by going here:

WHM>>Basic cPanel & WHM Setup

Under the Basic Config section there is an option to set the type of ethernet device. In the 'other' box type in 'lo venet0' and click save. This may resolve the emails you've been receiving, but I have never seen an instance of this error before and am not certain of the fix.
 

hoboman24

Registered
Feb 5, 2013
4
0
1
cPanel Access Level
Root Administrator
Glad you were able to fix the problem. As for the emails you are receiving, I am not certain about this but you may be able to fix it by going here:

WHM>>Basic cPanel & WHM Setup

Under the Basic Config section there is an option to set the type of ethernet device. In the 'other' box type in 'lo venet0' and click save. This may resolve the emails you've been receiving, but I have never seen an instance of this error before and am not certain of the fix.
Yeah, glad the email problem has been fixed, was just about to give me a headache.

I added the lo venet0 to the basic config other setting and saved, hopefully that helps.
:)