The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

About SMTP Port

Discussion in 'E-mail Discussions' started by Tymsah, Sep 6, 2007.

  1. Tymsah

    Tymsah Well-Known Member

    Joined:
    Apr 6, 2007
    Messages:
    151
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Hi,

    My server dont send email.

    How can i configuration in Firewall for Smtp 25 port allow.

    25 TCP In out or
    25 Udp in out

    Regards,
     
    #1 Tymsah, Sep 6, 2007
    Last edited: Sep 6, 2007
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Can you be more precise? Is it that you are connecting from a email client to your server and are unable to send mail? If so, it is likely that port 25 is blocked by your ISP (it's fairly common practice nowadays). Instead, set up Exim to also listen on port 26 and try connecting on port 26 instead.
     
  3. Tymsah

    Tymsah Well-Known Member

    Joined:
    Apr 6, 2007
    Messages:
    151
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    i am asking ISP and allow for 25 port.
    i think iptables block 25 port.
    csf (ConfigServer Security & Firewall ) install and running on server.
     
  4. linux.newbie

    linux.newbie Well-Known Member

    Joined:
    Sep 8, 2006
    Messages:
    73
    Likes Received:
    0
    Trophy Points:
    6
    WHM - Service Manager - Exim on another port - enable 26 and save
    Change the port from 25 to 26 on your email client and then check again.
     
  5. gribozavr

    gribozavr Member

    Joined:
    Aug 15, 2007
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    IMHO, not a really good idea -- other SMTP servers connect only to port 25, so you won't be able to receive e-mail from other servers.
     
  6. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Agreed, many administrators have Exim set up to listen on port 25 (since that's the standard port mail servers expect to connect to) AND port 26 (merely because it's not blocked by end-users' ISPs).
     
    #6 cPanelDavidG, Sep 7, 2007
    Last edited: Sep 7, 2007
  7. nomtek

    nomtek Registered

    Joined:
    Nov 18, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Thank You!

    Hi,

    I was on a shared server where the server admin didn't want to figure out why I couldn't send mail, but I'm sure this is why. My ISP (rogers) blocks port 25, which is dumb because EVERYONE uses port 25 for email. Anyways, I have to use port 26, which means that unless Exim is looking at port 26 for emails then I won't be able to send any. I'm now on a VPS with WHM and I love that I can fix things like this myself with very little experience and knowledge.

    Thank you for posting this info,

    Sean.
     
  8. tangowebs

    tangowebs Well-Known Member

    Joined:
    Oct 12, 2004
    Messages:
    93
    Likes Received:
    0
    Trophy Points:
    0
    some isp providers in argentina work with por 26...
    How can I make available both port 25 and 26 port on cpanel?
     
  9. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Go to WHM -> Service Configuration -> Service Manager and scroll to the bottom of that page. Check both checkboxes for Exim on another port and set the port to 26 then click save at the bottom of the screen.
     
Loading...

Share This Page