sinanata

Member
Jul 4, 2006
13
0
151
hi there guys.All of my accounts.On my server have the problem below.The problem's about the file owners and the permissions.All the files which uplaoded by a script or web based system has NOBODY as owner(for eg, a component file installed from the administration section of my joomla cms.) and all the new files have owner problem.

All of my resellers all of my shared hosting packages have this problem please can someone help me?
 

rikgarner

Well-Known Member
Mar 31, 2006
75
1
158
/dev/null
Are you using SuExec?

Rich
 

rikgarner

Well-Known Member
Mar 31, 2006
75
1
158
/dev/null
If I remember rightly, by standard, scripts run as the user "nobody", and therefore any files created by the script are chowned to nobody.

If you implement SuExec, scripts etc. run as the user account on the server.

If you have a look at page 120 of the WHM manual (download it and print out the PDF - its really useful!) it briefly describes SuExec.

In WHM, under Service Configuration, you have "enable/disable SuExec". Try enabling SuExec and see if that resolves your problem. Be aware however, that its possible that it will break something else, but we havent had any problems with SuExec ourselves.

Rich
 

rikgarner

Well-Known Member
Mar 31, 2006
75
1
158
/dev/null
Its possible that your build of apache did not contain SuExec support. You may need to rebuild apache (from the Software -> Apache Update menu) to include the SuExec module and the PHP SuExec support.

Click the boxes, hit "start build" cross your fingers, and when its done, try again :D

Rich
 

sinanata

Member
Jul 4, 2006
13
0
151
hi there again rich,

http://httpd.apache.org/docs/1.3/suexec.html heres some info about it.

I've made the selections you told me I've checked php support and the module of SuEXEC but it's not working again? still the owners of my files uploaded by my php program appears nobody and heres another problem which'll solved by suexec the owners appears as "[email protected]" I think after I set up suexec properly this'll appear as numbers?

right?

as the suexec documentation told us I've checked out the standart suexec directory written in that url and I couldnt find anything?

One more question must I create a new cpanel account for testing it?
 

rikgarner

Well-Known Member
Mar 31, 2006
75
1
158
/dev/null
Hiya,
No, you shouldnt need to create a new account.

If this problem is more complicated than SuExec not working, its getting a bit beyond my help im afraid. Maybe Chirpy will comment and point you in the right direction, else raise a Cpanel support request.

SuExec wont be doing any harm, and its worth having it installed.

Rich
 

fwwebs

Well-Known Member
Feb 16, 2004
329
0
166
Check your PHP information and see if the PHP API is CGI or Apache. CGI means PHPSuexec is enabled and scripts should be created with the owner being the cPanel account name. Under CGI, it will be owned and created by 'nobody'.

Code:
<?
phpinfo(); 
?>
 

rikgarner

Well-Known Member
Mar 31, 2006
75
1
158
/dev/null
Did you actually go through the Apache build?

Rich