The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Accepting all messages even invalid ones??

Discussion in 'General Discussion' started by 3tpro, Aug 7, 2007.

  1. 3tpro

    3tpro Registered

    Joined:
    Aug 14, 2005
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    We have begun to see the following issue occur, has anyone else?

    By doing telnet to our mail server and performing the standard helo commands etc the mail server takes the message no matter what. This is true even if the intended recipient is not a valid user on the system. Has anyone else seen this problem. We feel that the mail server should not take messages (No such user) if the intended recipient is not valid on the local system. These messages fill up our message queue as you can imagine as all messages are accepted.

    Note: These messages never get delivered they just sit in our queue.

    CP Version = WHM 11.2.0 cPanel 11.8.0-C16104

    === example ===
    250 our.mailserver.com Hello
    mail from: test@test.com -Fake from user
    250 OK
    rcpt to: test@test.com - Not Valid on our system.
    250 Accepted - Still takes the message
    data
    354 Enter message, ending with "." on a line by itself
    This is a test
    .
    250 OK id=1IIXt5-00058I-6k
    === example ===

    In the mainlog I get..
    2007-08-07 18:29:32 1IIYUS-0006d5-Ua == test@test.com R=lookuphost T=remote_smtp defer (-53): retry time not reached for any host
     
  2. lloyd_tennison

    lloyd_tennison Well-Known Member

    Joined:
    Mar 12, 2004
    Messages:
    698
    Likes Received:
    1
    Trophy Points:
    18
    Do you have catchall turned on? if so, then the system is doing exactly that - accepting all.
     
Loading...

Share This Page