cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
42
348
somewhere over the rainbow
cPanel Access Level
Root Administrator
If you are going to turn it on or off globally, you can do that in /usr/local/apache/conf/includes/pre_main_global.conf file.

If you set it in that file, you'd then want to restart Apache:

Code:
/etc/init.d/httpd restart
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
42
348
somewhere over the rainbow
cPanel Access Level
Root Administrator
You cannot do it in cPanel as far as I'm aware. If there were another way to do it that I knew besides command line to edit the file, I would have gladly suggested that option.

If this is a feature request to have that in WHM > Apache Configuration > Global Configuration area, I would be happy to move this thread to the correct location for feature requests. Please clarify exactly what you are wanting done.
 

alexandz

Well-Known Member
Oct 28, 2011
111
0
66
Chile
cPanel Access Level
Root Administrator
It happens that I have a website which delivers a report excel and pdf file to this the packages were installed to generate the files, including but not funiona htmldoc I can not see any reports.
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
42
348
somewhere over the rainbow
cPanel Access Level
Root Administrator
Do you have actual root SSH access to edit the file I mentioned initially in my first reply to either turn on or off AcceptPathInfo? Provided that is indeed what is causing the issue you are having anyway.

If you do not, then I suggest contacting your hosting provider who can access the backend of the machine to edit files in command line.
 

alexandz

Well-Known Member
Oct 28, 2011
111
0
66
Chile
cPanel Access Level
Root Administrator
errors after installing htmldoc

Install htmldoc since I have a website that requires a pdf file and other excel but I can not get these files.

Reviewing the logs got the following:
[Tue November 29 18:29:19 2011] [error] [client 190.121.92.154] HTMLDOC (29113) INFO: HTMLDOC 1.8.27 starting in CGI mode., Referer: http://xxxxx.cl/index.php? id = 360 & no_cache = 1 & view = 1 & uidsolicitud = 19321 & uidver = 12
[Tue November 29 18:29:19 2011] [error] [client 190.121.92.154] HTMLDOC (29113) INFO: TMPDIR is "(null)", referer: http://xxxxx.cl/index.php?id = 360 & no_cache = 1 & view = 1 & uidsolicitud = 19321 & uidver = 12
[Tue November 29 18:29:19 2011] [error] [client 190.121.92.154] HTMLDOC (29113) ERR005: PATH_INFO is not set in the environment!, Referer: http://xxxxx.cl/index.php?id = 360 & no_cache = 1 & view = 1 & uidsolicitud = 19321 & uidver = 12
[Tue November 29 18:29:19 2011] [error] [client 190.121.92.154] Can not open display:, referer: http://xxxxx.cl/index.php?id=360&no_cache=1&ver=1&uidsolicitud=19321&uidver = 12

If someone could help me, please.
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
42
348
somewhere over the rainbow
cPanel Access Level
Root Administrator
I've merged this post into the thread already started about the issue. I suggest asking these questions and researching them at htmldoc forum location. I found this discussion there:

Htmldoc PATH_INFO Issue

Their forum will know how to troubleshoot their errors.