The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Access denied for user - database

Discussion in 'General Discussion' started by Markwaugh, Oct 9, 2003.

  1. Markwaugh

    Markwaugh Well-Known Member

    Joined:
    Aug 12, 2003
    Messages:
    151
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Sydney, Australia
    Hello Guys,

    I am getting this error when i am trying to access a php page :

    Warning: mysql_connect(): Access denied for user: 'kiwi@localhost' (Using password: YES) in /home/kiwi/public_html/xx/ssinstall.php on line 17
    Can't connect to the database
    Access denied for user: 'kiwi@localhost' (Using password: YES)

    any ideas would be higly appreciated. Thanks in advance.

    cPanel.net Support Ticket Number:
     
  2. mjm2

    mjm2 Well-Known Member

    Joined:
    Oct 3, 2003
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    rm -rf /
    does the user kiwi have the correct permissions for the database he is quering?

    cPanel.net Support Ticket Number:
     
  3. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    Common mistake is for people to forget about including accountID_ in front of db name and mysql ID.

    cPanel.net Support Ticket Number:
     
  4. claven177

    claven177 Well-Known Member

    Joined:
    Sep 3, 2003
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Taipei
    I got the same error after 24 hours.
    Why it work yesterday, but now Access denied for user: yyyy


    Warning: mysql_connect(): Access denied for user: 'yyyy@localhost' (Using password: YES) in /home/yyyy/public_html/forum2005/sources/Drivers/mySQL.php on line 65

    Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /home/yyyy/public_html/forum2005/sources/Drivers/mySQL.php on line 68
    ERROR: Cannot find database yyyy_ipb2005
    Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /home/yyyy/public_html/forum2005/sources/Drivers/mySQL.php on line 101
     
  5. claven177

    claven177 Well-Known Member

    Joined:
    Sep 3, 2003
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Taipei
    I think it had better using user yyyy_yyyy, but why it can work when use user yyyy yesterday?
     
Loading...

Share This Page