The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Access denied - Invalid HELO name

Discussion in 'E-mail Discussions' started by skysel, May 31, 2012.

  1. skysel

    skysel Member

    Joined:
    Nov 30, 2010
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Hello fellow cpanel'ers,

    So I've migrated alot of customers from our old cPanel to new cPanel server. The issue I'm facing now is this:

    2012-05-31 10:31:20 H=11-111-11-111.ipv4.domain.si (compname01) [11.111.11.111]:59337 rejected MAIL <some.user@company-name.si>: Access denied - Invalid HELO name (See RFC2821 4.1.1.1)

    Thats our customer on the server. They complain that they could send mail on the old server WITHOUT SMTP authentication. I went through configs of old server (cPanel there was 3+ years outdated) but couldn't find any exceptions for this customer's IP to bypass SMTP authentication.

    So my question is following:

    Where can I add their IP on my new server, so they can send email without needing to use SMTP authentication?

    I've tried the whitelists in Exim Configuration editor but it appears not to be working. Any further ideas would be MUCH appreciated since this customer is a real pain in the... :)
     
  2. skysel

    skysel Member

    Joined:
    Nov 30, 2010
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Oh and I've already disabled HELO in configuration
     
  3. ruzbehraja

    ruzbehraja Well-Known Member

    Joined:
    May 19, 2011
    Messages:
    383
    Likes Received:
    7
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    is that your IP or the recipient servers IP?

    What if they login to POP before SMTP?
     
  4. lockefaltaba

    lockefaltaba Member

    Joined:
    Oct 24, 2012
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I agree; right this morning I've had to solve same issue and it was just because of accounts coming from old server not requiring SMTP authentication ....that's the point.: they had not checked the "My server requires authent."
     
  5. keithl

    keithl Member

    Joined:
    Jan 14, 2010
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    DataCenter Provider
    Not certain it's what you need, but have you tried adding their IP to /etc/skipsmtpcheckhosts, or checking if it's listed there on the old server? Suspect it's also viewable via cPanel though I'm not sure where (I set ours up ages ago and can't remember how that file came to have its current config).
     
  6. lockefaltaba

    lockefaltaba Member

    Joined:
    Oct 24, 2012
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Well I just told them all to check the "My server requires auth." checkbox and the HELO error message dissapeared from my logs.
    As for any kind of blacklistings I don't think it fits as customers change their IP from day to day.
     
Loading...

Share This Page