Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

"access-logs" directory no longer available through FTP after update

Discussion in 'General Discussion' started by supersoju, Jan 10, 2014.

  1. supersoju

    supersoju Registered

    Joined:
    Jan 10, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    On January 3rd we updated a CentOS server to WMH 11.40.1.9 (stable), and since this date we have been unable to connect to "access-logs" via FTP for any account on the server.

    This is also true for any absolute symlinked directory (but not "www"). When connecting via ssh / sftp we are able to change into the "access-logs" directory so it does not appear to be a file system permissions issue.

    Unfortunately, the workflow we are using dictates plain FTP and SSH/SFTP is not an option.

    FTP had worked previously as we have almost every of the 200+ sites setup to have their log files downloaded via FTP nightly.

    By default the server had been running pure-ftpd. We tested with pro-ftpd but the results were the same, cannot change in to the "access-logs" directory.

    We have tried editing /etc/pure-ftpd.conf changing "ChrootEveryone" to yes / no and setting "VIRTUALCHROOT" with not success.

    Setting "TrustedGID" to the Group ID of a test account allowed restored the ability of that one account to load "access-logs", along with the entirety of the filesystem. This is a step in the right direction, but not a valid solution.

    Again, this was working for years until the update on January 3rd.

    Any help would be appreciated.
     
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,803
    Likes Received:
    1,898
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello :)

    This behavior is by design per internal case 60471. Pure-FTPd will no longer follow symlinks because it is using traditional chroot instead of the virtual chroot that was used in 11.38 and earlier. You would have to setup a custom RPM for Pure-FTPd and compile it with the "--with-virtualchroot" flag to allow for this behavior.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice