The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Access server with ~username when FastCGI enabled

Discussion in 'General Discussion' started by kevinlevin, Feb 17, 2012.

  1. kevinlevin

    kevinlevin Member

    Joined:
    Oct 27, 2011
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi all,

    I am in the process of migrating to the FastCGI from SuPHP.
    When I am using SuPHP my clients can access their www directory by using:

    http://servername.com/~username/

    However, in several topics here I have read that FastCGI in SuEXEC mode doesn't allow such a behaviour..?

    Is there any way I can enable it for FastCGI?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    653
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    UserDir requests will not function correctly with FCGI (suEXEC enabled). The best workaround would be to skip using Apache mod_userdir and instead edit the hosts file on your personal machine to access the domain name over the IP address of the server you want to view it on.

    Thank you.
     
  3. kevinlevin

    kevinlevin Member

    Joined:
    Oct 27, 2011
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hmm I thought so after a bit of research.
    Thank you for your help.
     
Loading...

Share This Page