The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Accessing accounts with my ip and the account username is not working

Discussion in 'Security' started by project, Jan 2, 2012.

  1. project

    project Member

    Joined:
    Oct 27, 2009
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Greece
    cPanel Access Level:
    Root Administrator
    Hello to all!

    After a security update that my provider has made to my whm, i can't access my accounts via this url:
    http://IP/~username.

    When i enter this address i get this error:

    "404 Not Found

    The server can not find the requested page:

    xx.xx.xxx.xxx/~the_account_username/ (port 80)

    Please forward this error screen to xx.xx.xxx.xxx's WebMaster. "

    Where should i enable this feature?? I am using WHM 11.30.5 (build 3)

    Thanks in advance :)

    Kostas
     
  2. NixTree

    NixTree Well-Known Member

    Joined:
    Aug 19, 2010
    Messages:
    386
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Gods Own Country
    cPanel Access Level:
    Root Administrator
    Hello,

    This is Apche's mod_userdir feature. You can control this feature at " Main >> Security Center >> Apache mod_userdir Tweak" in your WHM.

    Add an exception to "DefaultHost (nobody)" from the above option, to have ~user access using server hostname / IP ( that is http://serverhostname/~user ) . Pleaes note that, this will limit ~access using hostname; access using any other URI will be disbaled.

    Thank you,
    Nibin.
     
Loading...

Share This Page