Accessing cpanel from public computers

nasplet

Member
Jun 9, 2011
11
0
51
Hi

I have recently migrated to my new VPS with WHM/Cpanel installed on it. I used to be at hostgator shared hosting.

I have problem accessing cpanel and WHM from some public computers.

When I enter domain.net:2083, I get:

Error 107 (net::ERR_SSL_PROTOCOL_ERROR):SSL protocol error.

I used to have the same problem at hostgator and their support told me to access the cpanel by going to cpanel.domain.net as some ports were being blocked. Can you please help me how to enable this solution to blocked ports on my VPS as well? Or any other method will do, just so I can access my cpanel from those computers also.

thank you very very much in advance!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,909
2,222
463
Hello :)

"Proxy Subdomains" should be enabled by default under the "Domains" tab in "WHM >> Server Configuration >> Tweak Settings". This will allow you to access services such as cPanel, WHM, Webmail, and Web Disk through Apache. If this is not working, please ensure the following Apache modules are installed on your VPS:

Mod_Proxy
Mod_Rewrite

If they are, could you confirm if the DNS for the domain name in question is handled on the same server, or is it handled by a remote server? If the DNS for the domain name is hosted elsewhere, you will need to manually add "A" entries at it's DNS host for the cpanel/whm/webmail/webdisk entries pointing to your server's IP address.

Thank you.
 

alphareseller

Member
Jun 26, 2011
7
0
51
Hi,

I have the similar issue but in the opposite way. I can access my WHM through secured port 2087, but unable to access to it without port number - https://whm.mysite.com. When I take the port out of the URL, I've got below error.

Error 107 (net::ERR_SSL_PROTOCOL_ERROR):SSL protocol error.

Is there any other settings that I need to change under WHM? I would like to access to my WHM without port number. Thank you.
 
Last edited: