The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Account creation failing issue (permissions)

Discussion in 'General Discussion' started by oulzac, Aug 14, 2008.

  1. oulzac

    oulzac Well-Known Member

    Joined:
    Aug 7, 2005
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    When creating a new account in WHM, I get two [an error occurred while processing this directive] messages at the top of the screen, then during Frontpage setup I see: /home/zzznewte/public_html does not exist or is not a directory!

    I check cpanels error log and I see this:
    tar: ./public_ftp: Cannot mkdir: Permission denied
    tar: ./public_html: Cannot mkdir: Permission denied
    tar: .: Cannot utime: Operation not permitted
    tar: .: Cannot change mode to rwxr-xr-x: Operation not permitted
    tar: Error exit delayed from previous errors
    (internal warning while parsing [stdin]) Thu Aug 14 19:01:52 2008 [20431] warn: safe_userchgid: chown: /home/zzznewte/public$
    Cpanel::SafetyBits::safe_userchgid(32510, 99, '/home/zzznewte/public_html') called at /usr/local/cpanel/Whostmgr/Acc$
    Whostmgr::Accounts::Create::_wwwacct('plan', 'Master3', 'maxpark', 'unlimited', 'lang', 'english', 'hasshell', 'y', $
    Whostmgr::Accounts::Create::_createaccount('customip', '--Auto Assign--', 'plan', 'Master3', 'language', 'english', $
    main::wwwacct called at whostmgr/bin/whostmgr.pl line 455


    (internal warning while parsing [stdin]) Thu Aug 14 19:01:52 2008 [20434] warn: safe_userchgid: chown: /home/zzznewte/.htpas$
    Cpanel::SafetyBits::safe_userchgid(32510, 99, '/home/zzznewte/.htpasswds') called at /usr/local/cpanel/Whostmgr/Acco$
    Whostmgr::Accounts::Create::_wwwacct('plan', 'Master3', 'maxpark', 'unlimited', 'lang', 'english', 'hasshell', 'y', $
    Whostmgr::Accounts::Create::_createaccount('customip', '--Auto Assign--', 'plan', 'Master3', 'language', 'english', $
    main::wwwacct called at whostmgr/bin/whostmgr.pl line 455

    What it does create, however is the /home/user folder, but nothing in it. So I check the /home/zzznewte folder in this case, and its only setting the permissions to:
    drwx------ 2 root root 4096

    when they should be:
    drwx--x--x 12 zzznewte zzznewte 4096

    I have rebuilt apache, forced two cpanel updates, nothing.
    this is a vps by the way, I have never seen this before :confused:

    What cpanel script file do I check/edit to correct this failed creation of the home/user folder?
     
  2. oulzac

    oulzac Well-Known Member

    Joined:
    Aug 7, 2005
    Messages:
    131
    Likes Received:
    0
    Trophy Points:
    16
    Issue resolved, its a problem with VPS main software HyperVM.
     
  3. sajan

    sajan Registered

    Joined:
    Jul 29, 2008
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    India
    Here is the fix ..

    Increase QUOTAUGIDLIMIT parameter using 'vzctl' utility on a node:


    Thank you,
    Sajan.S
     
Loading...

Share This Page