The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

account creation under freebsd

Discussion in 'General Discussion' started by manmythlgnd, May 3, 2002.

  1. manmythlgnd

    manmythlgnd Registered

    Joined:
    Apr 27, 2002
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hello. I am using (or rather, trying to use) the latest Cpanel under FreeBSD (a completely fresh install, done about 3 hours ago), however, when I try to create the account note the chpass and chattr errors (what's this about redhat 6.x?!). Consequently, I can't ftp in and when I upload files through the control panel. Any ideas?

    WWWAcct 2.5 by J. Nick Koston

    +===================================+
    | New Account Info |
    +===================================+
    | Domain: testdomain.com
    | Ip: &ip removed& (n)
    | HasCgi: y
    | UserName: testdom
    | PassWord: testdom
    | CpanelMod: default
    | HomeRoot: /usr/home
    | Quota: 200 Meg
    | NameServer: &nameserver removed&
    +===================================+
    User testdom added
    usage: chpass [-l] [-y] [-d domain [-h host]] [-a list] [-p encpass] [-s shell] [-e mmm dd yy] [user]
    Copying skel files from /usr/home/root/cpanel3-skel/ to /usr/home/testdom/
    Using redhat 6.x support
    Added Entries to httpd.conf (noip)
    Added DomainAlias Entry
    Added Named Entry
    Added Named File
    Added Remote Named File
    Frontpage 4 installer called when we really want 5 ..
    Attempting to pass request to frontpage 5 installer....
    Frontpage 5 installer loaded ok..
    Scanning httpd.conf..X..
    Removing .htaccess files
    Note: Local version of Apache must use the FrontPage Apache patch.
    Starting install, port: www.testdom.com.

    Creating web http://www.testdom.com.
    Chowning Content in service /.
    Install completed.

    Starting chown, port: 80, web: &/&.

    DocumentRoot: &/usr/home/testdom/public_html&
    Setting Password
    chattr: not found
    x - creating lock directory
    x - extracting /usr/local/frontpage/version5.0/apache-fp/fpexe2.patch (text)
    Patching fpexe2.patch
    Hmm... Looks like a unified diff to me...
    The text leading up to this was:
    --------------------------
    |--- fpexe.c.orig Thu Mar 7 20:30:45 2002
    |+++ fpexe.c Thu Mar 7 20:28:41 2002
    --------------------------
    Patching file fpexe.c using Plan A...
    Hunk #1 succeeded at 29.
    Hunk #2 succeeded at 172.
    Hunk #3 succeeded at 231.
    Hunk #4 succeeded at 246.
    Hunk #5 succeeded at 262.
    Hunk #6 succeeded at 273.
    Hunk #7 succeeded at 282.
    done
    chattr: not found
    Rebuilding DNS Zones List from master server .....
    Rebuild Complete
    Restarting apache
    Ftp Password Files synced
     
  2. manmythlgnd

    manmythlgnd Registered

    Joined:
    Apr 27, 2002
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I meant to say, when I upload files through the web control panel and try to hit the domain, I get a 403 (and consequently a 404 when it tries to execute an ErrorDocument clause).

    Thanks in advance.
     
  3. manmythlgnd

    manmythlgnd Registered

    Joined:
    Apr 27, 2002
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Found the solution... Plesk. Someone let me know when this is ready for prime time (like a beta that is even possible to test or use). I feel like a hypocrite for singing the praises of Cpanel on WHT now.
     
Loading...

Share This Page