The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Account creator using registry nameservers

Discussion in 'Bind / DNS / Nameserver Issues' started by apc1, Jan 25, 2007.

  1. apc1

    apc1 Well-Known Member

    Joined:
    Oct 18, 2004
    Messages:
    123
    Likes Received:
    0
    Trophy Points:
    16
    On on eof my servers whenever an account is created it somehome uses the parked nameservers of Go Daddy instead of the name servers specified in WHM.

    Of course when the user switches the DNS the sites will not work because the domain is still using the Go Daddy name servers.

    It only happens on that one server.

    How and why is it doing that and is there a solution please?

    Thanks!
     
  2. t9clkclnr

    t9clkclnr Well-Known Member

    Joined:
    Jun 11, 2004
    Messages:
    254
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Southern California
    check WHM Tweak SEttings

    Look at:

    When adding a new domain, if the domain is already registered, ignore the configured nameservers, and set the NS line to the authoritative (registered) ones.
     
  3. apc1

    apc1 Well-Known Member

    Joined:
    Oct 18, 2004
    Messages:
    123
    Likes Received:
    0
    Trophy Points:
    16
    Thanks, but I am not sure which option you are referring to.

    The default names servers are configured in WHM and when an account is created it should use those name servers surely?

    How and why is WHM using the parked nameservers?

    As fars as the account is concerned the parked nameservers are not relevant because the proper name servers will not become active until after the DNS is switched.
     
  4. rone

    rone Well-Known Member

    Joined:
    Jan 14, 2007
    Messages:
    179
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    The Netherlands
    cPanel Access Level:
    Root Administrator
    This has nothing to do with your WHM it is a Go Daddy thing.
    When a domainname is registered with Go Daddy it points to their parked page. The customer must change this in his "Domain Controle Centre" when he clicks on the domainname in his browser after that there is a button above the Controle Centre with "Nameservers" click on that one then you can choose for 3 options. Take the "Custom Nameserver" option and put there the nameserver address of your server. Save this all and then it is all done. It could take up to 48 hours till it points to the right nameserver. Thats all.

    Succes
     
  5. apc1

    apc1 Well-Known Member

    Joined:
    Oct 18, 2004
    Messages:
    123
    Likes Received:
    0
    Trophy Points:
    16

    I understand all that; thanks anyway; but that is not the issue.

    It still does not explain how WHM creates DNS zones with the Go Daddy parked name servers instead of the default name servers configured in the WHM settings.

    It is definitely a WHM thing because there is no way Go Daddy can access a remote WHM login or server, and alter all the DNS zone settings.
     
  6. t9clkclnr

    t9clkclnr Well-Known Member

    Joined:
    Jun 11, 2004
    Messages:
    254
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Southern California
    Check your WHM for the following:

    in Tweak Settings:

    "When adding a new domain, if the domain is already registered, ignore the configured nameservers, and set the NS line to the authoritative (registered) ones."

    There is a check box next to this. If this is selected, it's going to read and apply the nameservers from your registrar. If it is not checked it, will use your WHM default name servers.

    It's in wHM, under Tweak Settings. This should resolve your problem once you find it!

    And No, it is not a Go Daddy thing. As much as I would like to blame it on a go daddy thing.. :)
     
  7. apc1

    apc1 Well-Known Member

    Joined:
    Oct 18, 2004
    Messages:
    123
    Likes Received:
    0
    Trophy Points:
    16
    Thank you very much; that was it :)
     
Loading...

Share This Page