The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Account Move - MySQL Password Problems

Discussion in 'General Discussion' started by pfmartin, May 18, 2003.

  1. pfmartin

    pfmartin Well-Known Member

    Joined:
    Aug 18, 2001
    Messages:
    167
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    Hi All,

    I am trying to move an account across servers. The account has a MySQL database in it. The database itself is moved over, but the password is not moved over. I try to login to the newly created database on the new server and permission is denied.

    I checked the user table for both servers' databases. The password (encrypted) is different on each.

    This means that when I copy an account, the site will break because MySQL seems to have a new password for each database that is moved over.

    I have not testing what happens when the database has multiple users associated to it, so that may also be broken.

    Does anybody have an idea of what this might be and whether or not there is a fix?


    Some info that may help:
    1. I am running MySQL 4
    2. Both servers have the exact same release of WHM & CPanel.
    3. I have made sure the /scripts directory on both servers are the same (rsync -av rsync://rsync.cpanel.net/scripts /scripts)
     
  2. Nico

    Nico Well-Known Member

    Joined:
    Dec 5, 2001
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Edmond, OK
    We have had the same problem. If you remove the user from the database and then add them again it usually will correct that. Somtimes you just need to delete the use and re add them with the same password.
     
  3. pfmartin

    pfmartin Well-Known Member

    Joined:
    Aug 18, 2001
    Messages:
    167
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    Thanks for the feedback.

    That won't help much when we are copying multiple accounts. Our plan is to move many users from one server to another. Because of this mysql permission problem, we cannot do this. I know that it as working at some point because we have moved accounts across servers before. For some reason, it's now broken.

    Could it be the MySQL version 4 privelage table issues? Seems odd. Also, seems like a high priority fix is needed. I opened a ticket with DarkOrb, but I have never had good responses from them. I will keep this thread updated if I make any progress.
     
  4. pfmartin

    pfmartin Well-Known Member

    Joined:
    Aug 18, 2001
    Messages:
    167
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    Bump...

    I found out more. It turns out that the only user/password that does not work after the account move is the main account username and password.

    If a user had created a db user and associated it to the database, then it works fine.

    This means that part of the account move is working (as it pertains to databases). But the part that I most need working is not.

    DarkOrb support already responded to my ticket. The response is typical. Basically, I am on my own. Anybody have any suggestion on what I can do (other than slit my wrists)???

    Is there anyway to get priority support ?? I am growing increasingly disillusioned with Cpanel. If something does not work and it's not a high profile problem, you are screwed. Anyhow, that's my complaint and I am sticking to it. Thanks in advance for any answers/support/advice/grievances.

    cPanel.net Support Ticket Number: 14093
     
Loading...

Share This Page