The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Account will not login to cPanel using https:// but will login with http://

Discussion in 'General Discussion' started by wyattbiker, Feb 3, 2011.

  1. wyattbiker

    wyattbiker Member

    Joined:
    Nov 26, 2010
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    I have an account xyzadmin under the domain xyzdomain.com. When I try to connect to cPanel using xyzadmin with https://xyzdomain.com:2083 it fails to login but when I use http://xyzdomain.com:2082 logs in fine. So not a password issue.

    It is also on the domain for the main server (https://whm.xyzdomain.com:2087) which means it is on the same IP (i.e. shared) and same domain name.

    Also I can sftp using xyzadmin at xyzdomain.com without a problem.

    I have created other cPanel accounts on this same server but on their own IPs non shared that work fine with https://

    Can anyone help me figure why I cant use https to connect to an account that is on the shared IP?

    Thanks
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Can you try the main shared IP using https://IP:2083/ to see the results? Also, do you have a firewall running on the machine? If so, would you be able to disable it temporarily to see the results? It might be that the port 2083 isn't whitelisted for that IP in the firewall.
     
  3. wyattbiker

    wyattbiker Member

    Joined:
    Nov 26, 2010
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    I did try https://IP:2083/ and it worked only the first time. This is what I finally found out.

    Safari: After I clear the cache cookies, I can login using https://xyzdomain.com:2083 . Then i have to clear the cache to login again.

    Firefox: No problems.

    Chrome: Works but never logs me out even if I logout.

    Any ideas would be appreciated.

    Thanks.
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Are other users having this issue on your server or only your system? Have you tried on another system to log into that url with those browsers basically?
     
  5. coderiser

    coderiser Member

    Joined:
    Jan 31, 2011
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    i have seen issues with cpanel on chrome and safari from time to time like this. Usually it is users sepcific and may be linked to your personal computers software or a toolbar of some sort you have installed.

    Generally the biggest errors i see from chrome and safari with cpanel relate to ajax issues and the once stated above where it just never logs in.
     
Loading...

Share This Page