The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Accounts using subdomain as main domain no longer work

Discussion in 'General Discussion' started by thepatriot, Feb 6, 2009.

  1. thepatriot

    thepatriot Member

    Joined:
    Jun 16, 2006
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Ok so I updated to PHP5 today finally on my cpanel server and it appeared to go ok. However now the customers I had who were using a free subdomain for their main account domain are now having problems. The easiest way to explain is like this:

    We have a default domain setup on each server like this
    Default Domain on server8.host.com is: server8.com user: admin

    If a customer signs up without a domain we give them user1.server8.com as their main domain. Later some have parked a real domain on top like mysite.com parked on top user1.server8.com. Now after the latest PHP update these no longer work (mysite.com isn't even in httpd.conf anymore).

    Instead of user1.server8.com pointing to /home/user1/public_html like it used to
    It points to server8.com's account /home/admin/public_html as does user2.server8.com which was another account, so does user3.server8.com, etc.

    I know this is a bit confusing but hopefully it makes sense? Is there an easy way to fix this (as I've got 40+ servers setup like this)? I've tried rebuilding apache/php with the old restored up httpd.conf but that didn't work so now short of going in and manually editing each one I'm not sure what I should do.
     
  2. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,458
    Likes Received:
    22
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Please open a support ticket for this.

    Thank you.
     
Loading...

Share This Page