Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

accountsummary API no longer works?

Discussion in 'General Discussion' started by sparek-3, May 9, 2015.

  1. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,601
    Likes Received:
    64
    Trophy Points:
    328
    cPanel Access Level:
    Root Administrator
    Making an API call to the server using:

    Code:
    /json-api/accountsummary?api.version=1&user=USER
    on cPanel 11.46

    gives the response:

    Code:
    Array
    (
      [metadata] => Array
      (
      [version] => 1
      [reason] => API failure: Can't use an undefined value as an ARRAY reference at /usr/local/cpanel/Whostmgr/API/1/Accounts.pm line 66.
    
      [result] => 0
      [command] => accountsummary
      )
    
    )
    Same API call works fine on cPanel 11.44 servers.

    Haven't tried it on any other versions of cPanel.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    42,782
    Likes Received:
    1,712
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Are you entering a valid username when testing or actually entering "USER"?

    Thank you.
     
Loading...

Share This Page