The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ACL's

Discussion in 'User Experience' started by gorgo, Sep 2, 2002.

  1. gorgo

    gorgo Well-Known Member

    Joined:
    Jan 9, 2002
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    Im working on a new WHM Skin, and my ACL's don't seem to work... when I login as root... anything that has been ACL'd becomes removed... and I don't know why... Can someone please take a look at my command file for me? Its only partially done, but it should still be working!

    Thanks
    Kevin
     
  2. gorgo

    gorgo Well-Known Member

    Joined:
    Jan 9, 2002
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    Screen Shot

    a Partial Screenshot of my WHM Skin is complete....

    Currently the font faces are

    TITLE : Comic Sans
    Options : Arial

    I don't want to use these fonts if I don't have to, can anyone suggest better fonts to use?

    The screenshot is available
    http://66.78.7.92/whm-skin/screenshot.gif

    Please let me know what you think.
     
  3. awsol

    awsol cPanel Test Bitch

    Joined:
    Feb 8, 2002
    Messages:
    591
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Boston MA
    The ACLs don't seem to work ever. Nick don't know why. Drop him an email. He looked at my theme and he couldn't figure out why the ACLs didn't work.
     
  4. gorgo

    gorgo Well-Known Member

    Joined:
    Jan 9, 2002
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    ya he looked at mine too once before and couldn't figure it out... I guess it means that themes can only be used for Root users then?
     
  5. awsol

    awsol cPanel Test Bitch

    Joined:
    Feb 8, 2002
    Messages:
    591
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Boston MA
    As of right now that's how it seems. Really a pain but maybe someday Nick will fix it.
     
  6. gorgo

    gorgo Well-Known Member

    Joined:
    Jan 9, 2002
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    I can't see it being fixed anytime soon.. it seems as though cpanel 4 is slowly dying, and cpanel 5 is being developed... I haven't seen any major updates to 4.9 in over a month... Maybe the Cpanel version 5 will have what we need


    :)
     
  7. awsol

    awsol cPanel Test Bitch

    Joined:
    Feb 8, 2002
    Messages:
    591
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Boston MA
    cPanel will never die. Even if Nick gave up on it I'm sure somebody would buy it from him and pickup where he left off. I don't see Nick giving up on it anytime soon.
     
  8. gorgo

    gorgo Well-Known Member

    Joined:
    Jan 9, 2002
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    I didn't mean like that...

    Cpanel 4.9 doesn't seem to be developing much further, and now with CPmail 5.0 out, it looks as though we might be heading towards Cpanel 5.0 in the next few months :)

    I know Cpanel will never die... it has a huge customer base
     
  9. Juanra

    Juanra Well-Known Member

    Joined:
    Sep 22, 2001
    Messages:
    777
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Spain
    My ACL's seem to work well. Where's your command file?

    [quote:eff21f63dc]http://66.78.7.92/whm-skin/screenshot.gif[/quote:eff21f63dc]

    Can't load it:

    Forbidden
    You don't have permission to access /whm-skin/screenshot.gif on this server
     
  10. gorgo

    gorgo Well-Known Member

    Joined:
    Jan 9, 2002
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    my command file is in
    /path/to/cpanel/and/whmmgr/themes/theme2

    it also has a root file which points it too the command file, the root file is a redirect file... could that be the problem&

    TRY the link again pls
     
  11. gorgo

    gorgo Well-Known Member

    Joined:
    Jan 9, 2002
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    Sorry... issue was .htaccess was doing the HotLink protector and causing issues... HotLink was removed for this DIR
     
  12. Juanra

    Juanra Well-Known Member

    Joined:
    Sep 22, 2001
    Messages:
    777
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Spain
    [quote:74bb99ae8c][i:74bb99ae8c]Originally posted by gorgo[/i:74bb99ae8c]
    my command file is in
    /usr/local/cpanel/whostmgr/docroot/themes/theme2[/quote:74bb99ae8c]

    Gorgo I am not a cracker :p

    Anyway, the command file we are using is this:

    http://www.planhost.net/pruebas/command.html

    and it works for root and for resellers as well.
     
  13. gorgo

    gorgo Well-Known Member

    Joined:
    Jan 9, 2002
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
  14. Juanra

    Juanra Well-Known Member

    Joined:
    Sep 22, 2001
    Messages:
    777
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Spain
    [quote:6cfaac2971][i:6cfaac2971]Originally posted by gorgo[/i:6cfaac2971]
    a copy of my command file can be found
    http://66.78.7.92/whm-skin/command.html[/quote:6cfaac2971]

    It works well here (WHM 4.9.0, Cpanel 4.9.0-62)
     
  15. gorgo

    gorgo Well-Known Member

    Joined:
    Jan 9, 2002
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    my command file works there? or your command file works :)
     
  16. Juanra

    Juanra Well-Known Member

    Joined:
    Sep 22, 2001
    Messages:
    777
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Spain
    Your command file works here :)
    Well, at least the ACL's are working right.
     
  17. gorgo

    gorgo Well-Known Member

    Joined:
    Jan 9, 2002
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    DAMNIT!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    I think its just my WHM might need reinstalling...

    I'll have to talk to my Provider I guess... what do you think?
     
  18. awsol

    awsol cPanel Test Bitch

    Joined:
    Feb 8, 2002
    Messages:
    591
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Boston MA
    What the hell. Not fair. We must need something his system has. Maybe he has a recent build and we have the older ones.
     
  19. Juanra

    Juanra Well-Known Member

    Joined:
    Sep 22, 2001
    Messages:
    777
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Spain
    If you ask me, I think someone at Darkorb might inspect the problem.

    Perhaps you're right and the problem lies in the way the root file redirects to the command file.
     
  20. gorgo

    gorgo Well-Known Member

    Joined:
    Jan 9, 2002
    Messages:
    148
    Likes Received:
    0
    Trophy Points:
    16
    I'm running the same build... :) ....this sucks... :P Im thinking just telling to reinstall WHM and see what happens... hopefully someone from DarkOrb will see this forum sometime soon and provide some guidence :p
     

Share This Page