Activating nameserver failed on SUSE 10.0

GarnetR

Member
Aug 8, 2005
12
0
151
Going through the new server setup on CPanel 11 for a SuSE 10.0 box.

Tried to activate nameserver, and got this error:

Name Server Activated
Ensuring caching-nameserver is installed
unknown package caching-nameserver (ok)
Activating name server monitoring (chkservd)
Setting up rndc configuration
safe_chown: Error Fetching uid/gidChecking in /etc/named.conf to rcs system
safe_chown: Error Fetching uid/gidsafe_chown: Error Fetching uid/gidsafe_chown: Error Fetching uid/gidChanging ownership of /etc/named.conf: named:named
safe_chown: Error Fetching uid/gidRestarting Bind
Restarting Nameserver
Restarting chkservd
Stopping chkservd: [ OK ]
Starting chkservd: [ OK ]


I do have /var/named with normal looking stuff, and /etc/named.conf owned by root:root. I did not find an /etc/rc.d/named startup script.

/usr/local/cpanel/logs:
safe_chown: Error Fetching uid/gid @: at /scripts/cPScript/DNSLib.pm line 742
cPScript::DNSLib::find_rndckey('cPScript::DNSLib=HASH(0x812b180)') called at /scripts/fixrndc line 120
safe_chown: Error Fetching uid/gid @: at /scripts/cPScript/DNSLib.pm line 742
cPScript::DNSLib::find_rndckey('cPScript::DNSLib=HASH(0x812b180)') called at /scripts/cPScript/DNSLib.pm line 855
cPScript::DNSLib::loadrndckey('cPScript::DNSLib=HASH(0x812b180)') called at /scripts/fixrndc line 421
safe_chown: Error Fetching uid/gid @: at /scripts/fixrndc line 433
safe_chown: Error Fetching uid/gid @: at /scripts/fixrndc line 751
safe_chown: Error Fetching uid/gid @: at /scripts/fixrndc line 770
NSLib]: named-checkconf not located on system. Check your Bind installation. at /scripts/cPScript/Logger.pm line 35
cPScript::Logger::cplog('named-checkconf not located on system. Check your Bind instal...', 'warn', 'cPScript::DNSLib', 1) called at /scripts/cPScript/DNSLib.pm line 244
cPScript::DNSLib::checknamedconf('cPScript::DNSLib=HASH(0x812b180)', '/etc/named.conf.fixrndc') called at /scripts/fixrndc line 740


Ran:
apt-get install bind

responded getting: bind bind-chrootenv

/etc/rc.d/named now exists

Did back in browser window to re-run the activation step.

ps fauxwww|grep named now shows it running.

Problem solved....