Active vs Passive FTP activation?

Wax

Member
Jul 12, 2012
7
0
1
cPanel Access Level
Website Owner
Hello everyone,

I'm trying to trace down a small problem, which I'm not sure if it's having to do with my host.
(( I have a dedicated server ))

Since about 8-10 days ago, I have been unable to upload "active" ftp to my server.

The devices in question are a bunch of IP cameras, that upload their images via ftp.
This has been working fine for the past 2-3 years.

Yet 10 days ago, I got a lot of the cameras that suddenly stopped uploading their images (jpeg).
When I went on-site to one of the cameras, I couldn't get the ftp to work.
I got an error, which I'm including in the image attachments.

Yet when I tried to use "Passive mode" for the camera's ftp, it uploaded without a hiccup.

I'm interested in checking this out because, although I can change the cameras to use passive ftp, that means 3-4 days of driving around.

Is there a place I can check, if it even exists, the possibility of having "Active ftp" disabled?


Or is there anything you can suggest to check?

Thank you very much!
--AJ
 

NetMantis

BANNED
Apr 22, 2012
116
1
66
Utah
cPanel Access Level
DataCenter Provider
It means your host added a firewall to their server!

This however, generally speaking, is a very good thing! :)

(Technically speaking, the connection could also be cut by your own computer at home as well if you have a firewall installed on your home computer. Outbound FTP is often mistaken as inbound hacking attacks by commercial firewalls)

If the IPs are fixed from your cameras, you might be able to get your host to add an exception in the firewall for those specific IP addresses. Otherwise, yes your best recommended course of action would be to go to all your cameras and change the settings (really should of been using passive mode in the first place especially these days)

---- EDIT -----

I have a dedicated server
If your server is dedicated, you could just add the firewall exception yourself probably.

If running CSF, see /etc/csf/csf.deny and /etc/csf/csf.conf

The default config for iptables can actually interfere with FTP,
you can try removing /etc/sysconfig/iptables (the config for iptables)
and then restarting the iptables service.

Also, might take a look at /etc/pure-ftpd.conf which is where passive mode
FTP is actually configured and setup in the system.
 
Last edited:

Wax

Member
Jul 12, 2012
7
0
1
cPanel Access Level
Website Owner
Very good info.
Thank you for taking the time to reply.

I'm going to start visiting the cams... changing to Passive FTP.
In the same visit, I'm going to do something I should have done since installation... remote access.

Will update.
Thank you!