The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Actualizar a PHP 5.5.16 y Apache 2.4.10

Discussion in 'Discusión en Español' started by icp77, Sep 7, 2014.

  1. icp77

    icp77 Member

    Joined:
    Mar 15, 2005
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Buenas Tardes,

    quiero hacerles una consulta por favor, tengo que migrar un servidor a PHP 5.5.16 y Apache 2.4.10, las versiones actuales del servidor son PHP 5.4.32 y Apache 2.2.29.

    Mi pregunta es, si existe algun riesgo muy alto al migrar a estas nuevas versiones a travez de easyapache con whm, ya que no estan muy distantes las versiones, de las actuales en uso en este servidor.

    Tengo un cliente que no puede instalar owncloud por este tema, revisando los foros de owncloud al parecer funciona correctamente con PHP 5.3 o PHP 5.5, con PHP 5.4 falla o tiene problemas.

    Revisamos los modulos de PHP requeridos y estan habilitados.

    Gracias por su ayuda.
     
    #1 icp77, Sep 7, 2014
    Last edited: Sep 7, 2014
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    There are no risks with EasyApache itself, as it will fallback to the previous build if it fails to complete successfully. PHP offers a useful document for users upgrading to PHP 5.5:

    PHP: Migrating from PHP 5.4.x to PHP 5.5.x - Manual

    Thank you.

    Translation:

    Hola :)

    No existe ningún riesgo con sí EasyApache, ya que se replegará para la generación anterior si no se completa correctamente. PHP ofrece un documento útil para los usuarios que actualicen a PHP 5.5:

    PHP: Migrating from PHP 5.4.x to PHP 5.5.x - Manual

    Gracias.
     
  3. icp77

    icp77 Member

    Joined:
    Mar 15, 2005
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Buenos Días,

    gracias por la respuesta e información, el tema es que tengo un cliente que quiere instalar owncloud y sale este mensaje de error:

    Fatal error: Function name must be a string in /home/usuariodehosting/public_html/owncloud/3rdparty/Pimple/Pimple.php on line 122

    Es por este motivo, que me veo forzado ya actualizar estas versiones, obviamente sin la garantía de que funcione dicha instalación, ademas tengo otros usuarios que usan el servidor y no queremos afectarlos

    Gracias por sus comentarios.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    You may want to consult with the developers of that application to determine if it supports PHP version 5.5.

    Thank you.

    Translation:

    Es posible que desee consultar con los desarrolladores de esta aplicación para determinar si es compatible con PHP versión 5.5.

    Gracias.
     
Loading...

Share This Page