jameshsi

Well-Known Member
Oct 22, 2001
347
0
316
Hi!
I am trying to use an internal IP (192.168.100.XX) to backup some data to the other server in the same rack using same switch, so I go to /etc/sysconfig/network-scripts/ and add a ifcfg-eth0:1, then, I restart network by "service network restart" , am i doing wrong ?
It seems I doing big wrong, and all the IP are gone, so i add them back in WHM, but I still need to add the internal IP, how can I do that ?
Where did cpanel put the IP setting to ? I mean there must be some files like ifcfg-eth0:1 , pls let me know the correct way to do this.:confused:
 

BianchiDude

Well-Known Member
PartnerNOC
Jul 2, 2005
617
0
166
Hi!
I am trying to use an internal IP (192.168.100.XX) to backup some data to the other server in the same rack using same switch, so I go to /etc/sysconfig/network-scripts/ and add a ifcfg-eth0:1, then, I restart network by "service network restart" , am i doing wrong ?
It seems I doing big wrong, and all the IP are gone, so i add them back in WHM, but I still need to add the internal IP, how can I do that ?
Where did cpanel put the IP setting to ? I mean there must be some files like ifcfg-eth0:1 , pls let me know the correct way to do this.:confused:
Not 100% sure but I think you would need 2 nic cards and you would make eth1 the private IP, and connect that to the switch/vlan of your private network.
 

NeilAgg

Member
Dec 14, 2009
7
0
51
Houston, TX
Here is an example of ifcfg-eth0:0 from one of my servers:


DEVICE=eth0:0
BOOTPROTO=static
BROADCAST=[bcast]
HWADDR=[max]
IPADDR=[ip]
NETMASK=[netmask]
NETWORK=[network]
ONBOOT=yes

Note: It should not have a gateway specification.
Once you create the file, you should be able to do ifup eth0:0
 

jameshsi

Well-Known Member
Oct 22, 2001
347
0
316
It turn out to be very easy to add an internal IP to server, you just login to WHM, and add the IP ( 192.168.100.10) like what u do for public IP, and WHM will bind that IP without problem, but you just won't see any ifcfg-eth0:1 file in /etc/sysconfig/network-scripts/ .

On the other hand, if u manuly add that ip, like what u do in linux, u add a file called ifcfg-eth0:1, that might caused problem.