The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Add on script manager / Xoops

Discussion in 'General Discussion' started by cookiesunshinex, May 10, 2006.

  1. cookiesunshinex

    cookiesunshinex Well-Known Member

    Joined:
    Jun 10, 2005
    Messages:
    77
    Likes Received:
    0
    Trophy Points:
    6
    I have the add on script manager installed after some old pHPBB installs allowed a SQL injection attack on my server a few months ago.

    When Xoops was at version 2.0.13.1, I updated some of my xoops installs using the add on manager from 2.0.6 to 2.0.13.1.

    After the upgrade, I really wondered what actually happened. Was it SQL changes? I downloaded the source code and went through directory by directory and updated the PHP files. It didn't seem that the add on script manager did anything.

    I updated WHM/Cpanel today to 10.8.0 and 10.8.2-R83 today. I noticed that the Cpanel version of xoops is now at 2.2.3. Xoops forked a couple of versions ago, and it is now at 2.0.13.2 and 2.2.3. In other words, there is a 2.0.x and a 2.2.x.

    There are reasons for not upgrading to the latest version. Mainly because several modules haven't been updated to work in the new framework.

    So basically Cpanel users are left hanging if they had previously installed xoops through cpanel, and want to update to 2.0..13.2.

    We would like to use the add-on manager so we can go in quickly and easily update to the latest version to prevents SQL injection attacks like we did in the past

    Can anyone comment on this??
     
Loading...

Share This Page