The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

adding a domain without updating nameservers

Discussion in 'Bind / DNS / Nameserver Issues' started by MiHeath, Jul 27, 2012.

  1. MiHeath

    MiHeath Registered

    Joined:
    Jul 27, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hey gang, new around here, but I was hoping someone could help me out. I'm looking to add all of the content of a .com site I am migrating to a WHM/cpanel server, but I was hoping to test it on this server in an environment simulating the live version without actually pointing the A records to my WHM/cpanel host by using the Windows hosts file to point the traffic for me.

    When I go to create a new domain in cpanel, I receive an error that the nameservers are not pointing to this server yet. So to get around this I create the record required in /var/cpanel/userdata/xxxx/ , after doing so, I run /scripts/rebuildhttpdconf , yet the record is not showing up in /usr/local/apache/conf/httpd.conf .

    Any ideas on how to get this to work? I was thinking there might be a list of files or domains that the server uses to locate which files to use in /var/cpanel/userdata/xxxx/ or I have an error in my file in /var/cpanel/userdata/xxxx/ (completely possible, but doesn't seem likely).

    Thanks in advance!
     
  2. storminternet

    storminternet Well-Known Member

    Joined:
    Nov 2, 2011
    Messages:
    462
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Please go to your WHM > Main >> Server Configuration >> Tweak Settings and set
    Allow Remote Domains and Allow unregistered domains to On
     
  3. MiHeath

    MiHeath Registered

    Joined:
    Jul 27, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thanks! worked perfectly!
     
Loading...

Share This Page