Additional Destinations validation locked never ends

Operating System & Version
centos 7
cPanel & WHM Version
v88.0.13

ricardojds

Registered
Aug 18, 2020
4
0
1
Portugal
cPanel Access Level
DataCenter Provider
Hi,

I configured an additional destinations over sftp, the validation process is running after 3 hours,

Now i'm loked, i cant delete or create a new additional destinations.

Is there a comand line or something to cancel de current validation process
after 4 hours it timedout, is there a way to manualy force it, just for the next time. thanks
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,295
1,275
313
Houston
That shouldn't happen to begin with, there was clearly an error communicating with the remote server in this instance that caused it to stall. Was anything noted in the cPanel error logs? You can find them at /usr/local/cpanel/logs/error_log
 

ricardojds

Registered
Aug 18, 2020
4
0
1
Portugal
cPanel Access Level
DataCenter Provider
That shouldn't happen to begin with, there was clearly an error communicating with the remote server in this instance that caused it to stall. Was anything noted in the cPanel error logs? You can find them at /usr/local/cpanel/logs/error_log
Truem There was an erro comunication with the server, i didnt open the route in firewall, when, but after it was ok process was locked and i restarted the server that probably put the validation process on halt.

In the log i dint find anythin that looked related to the issue
 

jmartinmds

Member
Jul 22, 2016
15
3
53
Maryland
cPanel Access Level
DataCenter Provider
I'm having the same situation, except the validation status is still showing as in progress, even after a reboot. There's no active process that I can see. I removed the destination from the list via whmapi1 so there are currently no additional destinations listed, but I cannot create a new destination because the validation is still "in progress" even after a reboot.
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,519
1,031
313
cPanel Access Level
Root Administrator
Hey there, @TMZ Design - thanks for joining the forum!

When I've run into that in the past, it has almost always been a caching issue with your local browser. If the server was rebooted that would have killed any active processes.

Could you try checking that page on a different device or through a private/incognito browser to see if you still see the validation happening?
 

Mark Coates

Well-Known Member
Mar 13, 2019
98
12
8
Doncaster
cPanel Access Level
Root Administrator
hi i have this issue now. I have rebooted the server as well as tried incognito and other browsers and cleared the cache in them too.

i replaced the internet router for the backup server and clicked on validate to test connection to which i forgot to add the FTP port and then ever since this is stuck on validating.
 

Mark Coates

Well-Known Member
Mar 13, 2019
98
12
8
Doncaster
cPanel Access Level
Root Administrator
@Mark Coates - would it be possible for you to open a ticket on this issue? It may be good for us to see this issue in action so we can do some testing on our end. If you open a ticket, please post the number here so I can follow along and keep everyone updated.
Hi i have just logged in to see if its still there and its now gone back to normal so it wont work now although it has been about 3 hours before it was useable again, so im guessing it hit a timeout and then reset itself.

when i got back to it the backup was set as disabled so i re-validated and clicked enabled and now it all appears to be working again.
 

AlDocTHorXJ

Registered
Oct 29, 2019
2
0
1
Germany
cPanel Access Level
Root Administrator
Hello there,

I'm having the same issue. I hope someone can help me out.

I tried to add a new FTP destination but it went to " Validating … " endlessly.
It's been more than a day but it's still not fixed. Tried restarting the server several times. Also tried using other browsers, still got no luck.

I also tried to delete destinations from whmapi and ssh (/var/cpanel/backup/). The destinations are gone but the damn validation is still there and doesn't let me add new destinations or edit existing ones. Any help would be appreciated.

v100.0.4 / Centos 7.9
 

cPanelAnthony

Administrator
Staff member
Oct 18, 2021
975
95
103
Houston, TX
cPanel Access Level
Root Administrator
I'm so sorry, but the link provided opens up this very topic. After more than 30 hours, it's still validating.
My apologies, I meant to link another topic, but it seems irrelevant now. Could you open a ticket using the link in my signature so we can investigate? If you cannot, your web hosting provider should be able to.
 

unicaspa

Registered
Dec 2, 2021
2
1
3
Italy
cPanel Access Level
Root Administrator
Hello, here how i solved.

1) My validation failed because of CSF (firewall) blocking connections to the new destination. I added the new IPs to CSF's whitelist.
2) I removed the "disabled" attribute from the button "Validate all Destinations", using Chrome developers tools.
3) I clicked the button and the state updated immediately.

Hope this can be useful for others
 

Attachments

  • Like
Reactions: cPanelAnthony

cPanelAnthony

Administrator
Staff member
Oct 18, 2021
975
95
103
Houston, TX
cPanel Access Level
Root Administrator
Hello, here how i solved.

1) My validation failed because of CSF (firewall) blocking connections to the new destination. I added the new IPs to CSF's whitelist.
2) I removed the "disabled" attribute from the button "Validate all Destinations", using Chrome developers tools.
3) I clicked the button and the state updated immediately.

Hope this can be useful for others
Thank you for posting your solution!