The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

AddOn Domain email accounts hosed after suspension

Discussion in 'E-mail Discussions' started by jsteel, May 24, 2004.

  1. jsteel

    jsteel Well-Known Member

    Jul 4, 2002
    Likes Received:
    Trophy Points:
    Atlanta, GA
    We recently had a customer that was suspended. After reactivating the account, none of their add-on domain's email accounts were working. They found that if they went into their cPanel and forced a change to the password (using the same one as before) for the accounts, everything worked fine, which was quite odd.

    It appears that the suspension/unsuspension script is hosing up the shadow file for the add-on domain during reactivation. To run a test, we restored the shadow file from last night's backup and all of the accounts failing stated working just fine again. The only difference between the two files is that the restored version had a series of 7 semi-colons (":::::::") at the end of each line. For some reason it appears cPanel is stripping those out on the unsuspension and it is causing the issue.

    Has anyone else seen this problem?
  2. dario2

    dario2 Member

    Sep 21, 2002
    Likes Received:
    Trophy Points:
    I've been having that problem as well (9.3.0-RELEASE 5)! I hadn't noticed it was because of the missing semicolons from shadow, thanks! The following shell code should patch that for you real quick:

    find /home/USER/etc -name shadow | xargs grep -L ::::::: | xargs perl -pi -e 's/\n/:::::::\n/g'
    (where USER is the account name). Let's hope it's fixed soon.


Share This Page