Addon Domain going to account domain

dvent87er

Registered
Jan 28, 2007
4
0
151
For some reason when I add a domain it points the addon domain to the root domain.

even though I set it up like this:

Addon Document Root Username

addondomain.com /home/public_html/folder/ assignedusername


Setup on server:

- Using the theme X3
- CentOs 5 OS

Cheers

Any possible solutions are welcome :)
 

dvent87er

Registered
Jan 28, 2007
4
0
151
Some More Addon Domain Problems

I have searched around some more on this forum and have found various similiar problems with X3 theme I am running. Also addon domains not recording entries.

However, I looked at my named.conf and it did record the addon domains.

My problem is that the addon domain is showing the root open directory of server and need to fix this. Any Solutions?

Cheers
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
79
458
cPanel Access Level
Root Administrator
What is your full cPanel version number?

The following scenario works for me:

1. Login to cPanel
2. Click Addon Domains
3. Populate the fields like so (this is for example purposes only):
New Domain name: example.com
Subdomain/FTP Username: example
Document Root: public_html/example.com
Password: abc123

The directory /home/user/public_html/example.com is created and is added to httpd.conf as the document root.
 

dvent87er

Registered
Jan 28, 2007
4
0
151
What is your full cPanel version number?

The following scenario works for me:

1. Login to cPanel
2. Click Addon Domains
3. Populate the fields like so (this is for example purposes only):
New Domain name: example.com
Subdomain/FTP Username: example
Document Root: public_html/example.com
Password: abc123

The directory /home/user/public_html/example.com is created and is added to httpd.conf as the document root.
Yeah thats exactly what I do but the addon domain doesnt see /home/user/public_html/example.com but rather it shows /home/user/public_html/

Basically each addon domain shows the all the addon domains in the account.

Perhaps is there a setting I missed or forgot to turn on/off?
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,607
79
458
cPanel Access Level
Root Administrator
Cpanel Version Number is: 11.16.0-R18546
and
WHM Version Number is: 11.11.0

Cheers
Would you mind opening a support ticket for this issue at https://tickets.cpanel.net/submit/ ?

I cannot re-create the issue on any of our test systems, which indicates something else is happening, something that doesn't match our test environment and your environment.
 

mindaugas

Member
Jan 28, 2009
6
0
51
I got cpanel from a reseller so I am not sure of my account info. Before I look that up I thought I would post here. I have the exact same problem. I checked the httpd file and everything looks ok but the addon domain is displaying the master domain. Here is the entry from the httpd file.

<VirtualHost 74.55.24.146:80>
ServerName apudgykitten.ourlifewithouttv.com
ServerAlias apudgykitten.info www.apudgykitten.info
ServerAlias www.apudgykitten.ourlifewithouttv.com
DocumentRoot /home/ourlifew/public_html/apudgykitten.info
ServerAdmin [email protected]
UseCanonicalName off
## User ourlifew # Needed for Cpanel::ApacheConf
ourlifewithouttv.com actually doesn't point to the server yet. apudgykitten.info does point the server but when I try it brings up the content for ourlifewithouttv.com. (ourlife is currently transferring)