The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Addon Domains Disappeared

Discussion in 'General Discussion' started by ho247, Mar 16, 2003.

  1. ho247

    ho247 Active Member

    Joined:
    Mar 25, 2002
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    United kingdom
    Can anyone provide some advice about addon domains simply disappearing? They are showing in the /var/cpanel/user/USERNAME file, but they don't show up in the Cpanel control panel. The domains are also listed in the /etc/userdomains file.

    Alan
     
  2. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    What build is this in?

    What is the support ticket id?
     
  3. ho247

    ho247 Active Member

    Joined:
    Mar 25, 2002
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    United kingdom
    The support ticket id is 9777 and the server is running "Cpanel 6.0.0-R108".

    Alan
     
  4. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    should be resolved as per

    6.0.0-EDGE_122

    cpanel wasn't displaying second level subdomains

    ie

    a.b.domain.com
     
  5. ho247

    ho247 Active Member

    Joined:
    Mar 25, 2002
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    United kingdom
    Thanks for that... I did consider upgrading to the EDGE version as I've read changes have been made related to the addon domains in the ChangeLog file, but I was wondering if there was a fix for the RELEASE version. But thanks for fixing it.

    Alan
     
  6. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    should be 10 days before it finds its way into RELEASE
     
  7. Sketch

    Sketch Active Member

    Joined:
    Jan 1, 2003
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Baltimore, MD
    IS this the same thing with email domains not showing up. WE have a user who has added an addon after much problems and coordinating with us (account ownerships, etc) but he still can't add an email to that domain. The domains subdomain is available, but not the domain itself.
     
  8. krellen

    krellen Member

    Joined:
    Oct 1, 2002
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Have the same problem as Sketch. The addon domain is there, but can't add email addresses for it.
     
  9. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    All eMail to an Add-on Domain is automatically sent to the default eMail address for the 'main' account.

    If you want eMail for the Add-on Domain to be seperate, as in 'sent to' or allowing someone else to have access to it, then you need to setup a re-direction using Cpanel.

    E-Mail
    Manage Accounts > Add Account
    Forwarders > Add Forwarder

    The Add-on Domain will appear in the drop-down list.


    Drawback is that you cannot setup a 'catch-all' account like you can for the 'main' account. Each eMail address must be individually entered.
     
    #9 Website Rob, Apr 17, 2003
    Last edited: Apr 17, 2003
  10. jackal

    jackal Well-Known Member
    PartnerNOC

    Joined:
    Feb 23, 2002
    Messages:
    708
    Likes Received:
    0
    Trophy Points:
    16
    Do this go into whm delete dns zone for that add on domain. Then go into the sub domain it created when you made the add on domain in the control panel once there copy all your files from the sub domain.
    Then go into control panel delete add on domain then go to sub domains and delete the sub domain that went with the add on domain.

    Now go back and recreate the add on domain, and try email addition with that add on domain. Then upload files back into sub domain.

    Should work it just did for us, we had same problem when moving a account from one server to another server via the whm move account option.

    Hope this works for you.
     
Loading...

Share This Page