The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Addon Domains, URL address and pictures

Discussion in 'Security' started by SeaComms, Jul 7, 2006.

  1. SeaComms

    SeaComms Registered

    Joined:
    Jul 6, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Addon Domains with URL redirect masking - no pictures

    Hi all,

    I am new to the cpanel world and am in the process of setting up my own web site with no problems. I am setting up a small site for a friend and have setup a new domain name and registered it in cpanel as an addon domain with redirection to the folder for the subdomain. I have created a temp single page site with a couple of pictures within the subdomains directory and have it working sort of, with the following exceptions....

    I am not able to have BOTH the address bar in ie6 show the correct url name AND show the pictures! I have been searching hi and lo and found several instances of both prolems and I can solve either, but not both simultaneously.

    It seems that if I have the hotlink protection disabled, the adress bar shows the correct url (jpcleaning.biz) but the pictures wont show. If I enable hotlink protection and place the subdomain in there, the pictures now show, but for some reason I now have the adress bar showing maindomain.com.au/subdomain.

    Can anyone help? I am going mad here!

    Dave.

    EDIT: I tracked down a mod to the .htaccess file that has succesfully completed the url redirection masking, but now if i use the addondomain.biz or addondomain.maindomain.com I get no pictures, if i use maindomain.com/addondomain i get "page cant be found"...
     
    #1 SeaComms, Jul 7, 2006
    Last edited: Jul 7, 2006
  2. SeaComms

    SeaComms Registered

    Joined:
    Jul 6, 2006
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Solved it

    For anyone interested, I have discovered (with the help of my son..) that the masking of the url has caused an error in the location of the pictures.

    To explain: The addon domain (or subdomain) has its own folder within the main domain. When creating the web page for this subdomain (jpcleaning) the pictures had the properties of /jpcleaning/images/picturename.jpg. When no redirection was in force, all works fine. When the redirection was activated, the url of jpcleaning.biz was pointed to the subfolder jpcleaning within the main domain (ie, not the root). When looking at the now-not-showing pictures in a web browser, the properties of the pictures now show jpcleaning.biz/jpcleaning/images/picturename.jpg. Since the subdomain was already pointing to the jpcleaning directory, it was looking for a second subdirectory called jpcleaning with an image folder for the pictures (ie, was looking for /root/jpcleaning/jpcleaning/images/picturename.jpg which does not exist).

    I still do not know the proper way to fix this, but as a temporay solution I have created a second jpcleaning folder within the existing one and copied the image folder into it. I decided on this rather than just moving, as when using the html editor within cpanel without the original images location they do not show in there (as there is no redirection in force when working within the html editor!)

    If anyone has any ideas on how to fix this properly I would be very appreciative!

    Cheers, Dave.
     
    #2 SeaComms, Jul 8, 2006
    Last edited: Jul 8, 2006
Loading...

Share This Page