Blue Optic

Member
Feb 6, 2003
13
0
151
My Version:

WHM 6.0.0
Cpanel 6.0.0-E74
FreeBSD 4.7-RELEASE

Whenever a user creates an FTP account, the login does not work. The main account does--but not the addon.

I've checked:

/etc/proftpd/passwd.vhosts

and an entry IS added...but just doesn't work.

Suggestions?
 

Curious Too

Well-Known Member
Aug 31, 2001
428
1
318
cPanel Access Level
Root Administrator
Originally posted by Blue Optic
My Version:

WHM 6.0.0
Cpanel 6.0.0-E74
FreeBSD 4.7-RELEASE

Whenever a user creates an FTP account, the login does not work. The main account does--but not the addon.

I've checked:

/etc/proftpd/passwd.vhosts

and an entry IS added...but just doesn't work.

Suggestions?
Is the user logging in as "username[email protected]?"
 

Donna

BANNED
Feb 15, 2003
88
0
156
Toronto, Canada
Are they using the right hostname as well. If all else fails I just tell ppl to log into the server by it's name rather than the ftp.domain.com hostname
 

Blue Optic

Member
Feb 6, 2003
13
0
151
I'm FTPing from localhost to test it out---still doesn't work.

Can someone post their proftpd.conf file here?
 

Blue Optic

Member
Feb 6, 2003
13
0
151
Looked some more..

It's not adding any <VirtualHost> entries--should it be?

This is retarted..im paying for this and a main function isn't even working..
 

jeroman8

Well-Known Member
Mar 14, 2003
410
0
166
DID YOU FIX THE PROBLEM ?

WHAT WAS IT ???
I'm having the same problem :)))

HELP
 
X

X-Istence

Guest
I am having the same problem, if this could be fixed as soon as possible please, i have a web hosting business to run here.
 
Last edited by a moderator:

bluedog

Member
Aug 20, 2002
13
0
151
DAMN has this been fixed yet? What about all answers be posted so we can do a search and just get the answer instead of one person submit a ticket and a million more submit a ticket.
 

Epyon

Registered
May 7, 2003
1
0
151
Same problem..

Yea. I'm having the same problem. Did anyone else figure out what was happening? I'd love to know.

email me if you know, or just reply..
[email protected]

Cheers
 

rweiss

Well-Known Member
Aug 31, 2002
49
0
156
Same here

Same here :-(...

FTP accounts work, and then they randomly stop working... I didn't believe a few users when they were complaining about this "off and on" behavior... Still haven't quite figured it out.

-Russell

cPanel.net Support Ticket Number:
 

jeroman8

Well-Known Member
Mar 14, 2003
410
0
166
2-3 months and still not solved - this is really bad.
I contacted another company doing cpanel support.

They did a ktrace of the proftpd process while attempting to login to see what was happening. Upon viewing the ktrace file they noticed that that one of the calls was to /etc/pwd.db for the ID & PW. In the /var/log/auth.log they also noticed that the error "no such user found" was being showed.

It seems that in order for the FTP to work for the added accounts they must exist in /etc/pwd.db and at this point they do not.

cPanel.net Support Ticket Number:
 

jeroman8

Well-Known Member
Mar 14, 2003
410
0
166
Originally posted by bdraco
Does anyone have a ticket????

cPanel.net Support Ticket Number:
Here's mine: 11132
Jerry R

cPanel.net Support Ticket Number:
 

X-Istencedotcom

Well-Known Member
Apr 14, 2003
223
0
166
Have nick look into it, he fixed it on my server.

It should all work in cPanel 6.4.2

cPanel.net Support Ticket Number:
 

jeroman8

Well-Known Member
Mar 14, 2003
410
0
166
Who is Nick ?

And no, it doesn't work in 6.4.2 LOL, this is crazy !
Is there a way to reset everything that has to do with FTP
and get fresh files including the config files for FTP ?

Anyone know when Pure FTP will be availible for freedbs ?

Jerry

cPanel.net Support Ticket Number:
 

jeroman8

Well-Known Member
Mar 14, 2003
410
0
166
The proftpd was using the wrong config file !!
Someone fixed it yesterday - only took about 10 weeks LOL

cPanel.net Support Ticket Number: