Addon Script Manager 500 Internal Server Error

Trane Francks

Well-Known Member
Jun 19, 2012
102
19
68
Machida, Tokyo, Japan
cPanel Access Level
Root Administrator
Hey, all.

Since our recent upgrade to 11.38.1.6, I'm seeing 500 Internal Server Error when trying to access the Addon Script Manager CGI script. I'm seeing:

Internal Server Error

500

No response from subprocess (/usr/local/cpanel/whostmgr/docroot/cgi/addon_addonupdates.cgi): subprocess exited with status 2

cpsrvd/11.38.1.6 Server at (my server here)

~~~~~

What, if anything, can I do to resolve this?

Cheers!:rolleyes:
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,205
363
Hello :)

There is likely a missing Perl module that is keeping it from loading. You can review the cPanel error log (/usr/local/cpanel/logs/error_log) to see which specific Perl module is missing. However, the functionality of "addon_addonupdates.cgi" was replaced by the cPAddon system several years ago. I recommend that you discontinue using this plugin and remove it from your system.

Thank you.
 

Trane Francks

Well-Known Member
Jun 19, 2012
102
19
68
Machida, Tokyo, Japan
cPanel Access Level
Root Administrator
Please could you explain how to remove this from the server?
The answer lay in the error itself: '/usr/local/cpanel/whostmgr/docroot/cgi/addon_addonupdates.cgi'. Log into your server and either delete the file from the command line, e.g., 'rm -f /usr/local/cpanel/whostmgr/docroot/cgi/addon_addonupdates.cgi' or use a file manager in WHM. Whichever way you choose, you'll need root privileges. Once the file is removed, the errors will go away.