Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED Adventures with EA4

Discussion in 'EasyApache' started by rpvw, Oct 6, 2016.

  1. rpvw

    rpvw Well-Known Member

    Jul 18, 2013
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    I'm told I worry too much. Its probably true. I worry about my Boss and his company. I worry about my ability to run his servers, and most of all, I worry about our customers and the trust they put in us to keep their websites up and running ....... and now I have to worry about worrying too much !

    Then there are the small worries, like EA4 which I have only been worrying about since it started to tickle my consciousness back in January 2015. Frankly the prospect of a visit to the dentist appealed to me more than the pain I was expecting to endure during the EA3 to EA4 conversion process !

    So first a bit about the server – fully patched Cloudlinux on CentOS 6 dedicated box with 8 core CPU and WHM 58.0 (build 31) configured to use CloudLinux LVE Manager, alt-php, Cage-FS and MariaDB 10 ..... all happily working together in perfect harmony with EA3 :)

    Non of my sites used the cPanel default PHP – all were on alt-php and I even had the cPanel native PHP disabled.

    I can't put it off any longer ......................

    I followed the instructions at the Cloudlinux documentation Migrating to EasyApache 4 page using the default suggestions and ...... well ....... (it should come as no surprise) ..... it worked beautifully !

    There was some inevitable tidying up of some domains to do, principally in changing htaccess defined AddType Application lines to reflect the new php paths but that was quickly sorted.

    The cron jobs all seem to work, and the monotonous Suspicious Process alerts from CSF needed the new php-cgi executable paths adding to the csf.pignore file.

    An irritation was observed from the security advisor reporting suEXEC is disabled. The cPanel forums mention Case CPANEL-7731: The cPanel EA 4 suexec binary uses capabilities, but CloudLinux's uses the setuid bit. Detect both cases properly. Unfortunately, the fix doesn't seem to be scheduled until v 60 which is only just about to hit current – so we may have to wait and worry a bit more about that (what a relief I found something to continue worrying about).

    So a huge thank you to everyone that contributed to, and worked, on the EA3 to EA4 migration process, and to all the developers of EA4. You guys are all rock stars and you still forget that us mere mortals need to be hugged and reassured and cosseted sometimes.
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #1 rpvw, Oct 6, 2016
    Last edited: Oct 6, 2016
    dazeck, cPanelMichael and Infopro like this.
  2. cPanelMichael

    cPanelMichael Technical Support Community Manager Staff Member

    Apr 11, 2011
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    Hello @rpvw,

    I realize this is an older thread and was opened purely to provide feedback, but I did want to provide an update for anyone browsing it in the future to note that the resolution for CPANEL-7731 was included as part of CPANEL-9952 in 60.0.26:

    Fixed case CPANEL-9952: Update Security Advisor to the latest version.

    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice