The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Affraid to update....

Discussion in 'General Discussion' started by yodabear, Jul 27, 2006.

  1. yodabear

    yodabear Member

    Joined:
    May 31, 2005
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Hi all,

    Since a while i got after i'm logging in the screen that there some updates waiting.

    At the moment PHP Version 4.3.11 is running on my cPanel server. But i see in the update list:

    PHP Current version: 5.1.4/4.4.2 Installed version: 4.3.11

    I'm affraid that when i'm going to update it will install PHP Version 5.1.4 and some websites won't work fine anymore.

    Who can help me with this one?

    Thx in advance!
     
  2. yodabear

    yodabear Member

    Joined:
    May 31, 2005
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    So with other words you say i can do it safely??
     
  3. DigiCrime

    DigiCrime Well-Known Member

    Joined:
    Nov 27, 2002
    Messages:
    399
    Likes Received:
    0
    Trophy Points:
    16
    If sites dont work anymore itll be because their not compatible with the PHP version that you installed, not because you upgraded Nothing you can do about that if the customer doesn't want to upgrade their script. I still see customers using ancient php versions and upgrade them to newest 4x to/from/or 5x everything goes smooth
     
  4. DigiCrime

    DigiCrime Well-Known Member

    Joined:
    Nov 27, 2002
    Messages:
    399
    Likes Received:
    0
    Trophy Points:
    16
    kinda odd, your post before mine lol

    Every cpanel box is different I wont say you can or can't just basing it on my own experience I haven't had a problem with it.
     
  5. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    7
    Trophy Points:
    0
    ROFL! :D :D

    You can install whatever PHP version you wish and that goes for
    both Easy Apache and manual PHP installations.

    However just as a side note to you, PHP 5.1.4 works fine with all web sites
    and won't cause you any problems whatsoever if installed correctly!

    There seems to be a lot of confusion out there with PHP v5 and MySQL v5 ...

    PHP v5 -- backwards compatible to v4 and any real problems is EXTREMELY RARE!

    MySQL v5 -- A lot of scripts and programs are still not compatible with MySQL v5

    I generally recommend that hosts upgrade to PHP v5.1.4 right now but wait on upgrading to MySQL v5 until later
     
Loading...

Share This Page