The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

After 11.50.0 upgrade, Spamd is shown as down in Service Status

Discussion in 'E-mail Discussions' started by monkey64, Jun 17, 2015.

  1. monkey64

    monkey64 Well-Known Member

    Joined:
    Nov 6, 2011
    Messages:
    86
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    After 11.50.0 upgrade, Spamd is shown as down in service status.

    Code:
    /scripts/restartsrv_spamd --status
    
    outputs the following:

    Code:
    spamd (/usr/local/cpanel/3rdparty/perl/514/bin/spamd --daemonize --max-spare=1 --max-children=3 --allowed-ips=127.0.0.1 --pidfile=/var/run/spamd.pid -i127.0.0.1) is running as root with PID 10955 (pidfile check method).
    
    so I assume that it is running. However I get I get a red indication in Service Status as well as a warning email. Everything else is up. BTW: I am running version 3.4.0.
    I have performed a restart:

    Code:
    /scripts/restartsrv_spamd
    
    and the message in green is "spamd restarted successfully" so it looks as though WHM is not detecting that it is running. Any ideas?
     
  2. 24x7ss

    24x7ss Well-Known Member

    Joined:
    Sep 30, 2014
    Messages:
    271
    Likes Received:
    16
    Trophy Points:
    18
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    Did you check error logs for cPanel when you access the service status ? Are there any errors ?
     
  3. monkey64

    monkey64 Well-Known Member

    Joined:
    Nov 6, 2011
    Messages:
    86
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    I just received a RECOVERED email from WHM with the text The service “spamd” is now operational.

    It is now correctly shown as working in Service Status. How strange.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    675
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    I've not seen any additional reports of "spamd" failures after the update to cPanel version 11.50. It's possible the service failed during the update, and did not show as "up" until it was restarted by Chkservd. Let us know if you encounter any additional issues related to this.

    Thank you.
     
Loading...

Share This Page